#1
I have a Marshall MG100 Fx half stack solid state amp. I know. Looking to upgrade but for now this is all I have. I just moved it back from a friends house and when I turn it on it makes a ear splitting screeching noise. I have no guitar plugged in and the volume turned all the way down. When I unplug the cord connecting the head and cabinet it doesn't screech. What is causing this? Cord possibly?
#2
My first guess would be a faulty op-amp.
Gilchrist custom
Yamaha SBG500
Telecasters
Randall RM100 & RM20
Marshall JTM45 clone
Marshall JCM900 4102 (modded)
Marshall 18W clone
Fender 5F1 Champ clone
Atomic Amplifire
Marshall 1960A
Boss GT-100


Cathbard Amplification
My band
#4
If you are a tech. It could be quite a few things though, that would just be my first guess. Somebody would have to pull it apart and do diagnostics and at say, $50 per hour it could easily add up to some real money. Fixing is rarely where the money is, it's labor.
Gilchrist custom
Yamaha SBG500
Telecasters
Randall RM100 & RM20
Marshall JTM45 clone
Marshall JCM900 4102 (modded)
Marshall 18W clone
Fender 5F1 Champ clone
Atomic Amplifire
Marshall 1960A
Boss GT-100


Cathbard Amplification
My band
#5
Don't unplug the cable connecting the head and cab while it's on.
Also only use a speaker cable for that, never a regular guitar cable.

Also, my friend's MG used to do this too when the fan didn't turn on. He had to flip it on and off until the fan started.

Quote by emad
jthm_guitarist
Warned for trolling!


Quote by metal4eva_22
Didn't you say that you had a stuffed fox that you would occasionally fuck?

Quote by Axelfox
It's not a fox,it's a wolf.
#6
Quote by therapture
I have a Marshall MG100 Fx half stack solid state amp. I know. Looking to upgrade but for now this is all I have. I just moved it back from a friends house and when I turn it on it makes a ear splitting screeching noise. I have no guitar plugged in and the volume turned all the way down. When I unplug the cord connecting the head and cabinet it doesn't screech. What is causing this? Cord possibly?

I've got a 30CFX, try to connect the head + cab with a Mogami speaker cable.