#1
So I'm trying to use Logic Express 8 with an Apogee Duet to DI record a Guitar to start my project, but even though (I believe) that I have the settings right, I'm not hearing my guitar through my monitor (headphones). All my cables work and are connected in what should be the right places, the volumes and gains should be at adequate levels, and what stumps me the most is that the Duet still functions as a microphone interface and is even still picking up sounds through the microphone despite the control panel saying the input is set as the Instrument. I've muddled with it before way in the past and gotten the DI to work but I don't remember how I did it or if there were other steps than just going to the control panel and switching it from mic to instrument. I understand Logic is better suited for MIDI, but this should still be doable and I'm upset tat its fighting me.

I'm really set on going DI for two main reasons. 1) I've never been happy with the tone I get from mixing my amp in my not sound treated atmosphere and want to see if I'll get better results this way, and 2) I'm usually only free to record in the wee hours of the night and I don't want to wake my roommates up with live playing. For my roomies's sake, can ya help a guy out?

Screenshot depicting current windows and settings:
http://i250.photobucket.com/albums/gg248/androidred0100/ScreenShot2013-11-01at101827PM.png

Gear used:

Epiphone SG
Monster Cables Rock Guitar Cable
Apogee Duet
Logic 8 Express
2007 Macbook Pro
Hosa Headphones (monitor)
MY GEAR
Epi SG w/ Gibson Burstbuckers
Epi Casino
PRS Kit
Thinline Tele w/ SD 1/4 Lbs
Warmoth JM

Vox Nightrain
Marshall Class 5

Boss RC-20
DT EX-7
EHX Q-Tron +
EHX Big Muff Pi w/ Tone Wicker
Line 6 Echo Park

My PRS with SD P-Rails Build
#2
Is software monitoring on?

Logic preferences>audio>software monitoring (I think)

Can't help with the duet still functioning as a mic - never used that particular interface.
RIP Gooze

cats
#3
(firstly just a quick point, Logic is not more suited to MIDI, it does audio recording very well)

Firstly, try turning the input monitor on for that channel (green "i" button next to record enable. Then turn software monitoring on.

Are you seeing signal on the Duet? Are you seeing signal in Logic? Are you seeing signal at the headphone output? (by seeing signal I mean is it metering).
#4
Hey, sorry for the super late response. My roommates and I couldn't afford our internet bill for a bit and they cut our service for a few weeks until we could pay it off.

I tried clicking the I button, still nothing.

The Duet reads signal from the mic input regardless of what the software says its supposed to be reading signal from but its still not reading anything from the Instrument inputs. I've tried a bunch of different instrument cables that all work and I've tried a bunch of different guitars that all work, so the problem isn't there.
MY GEAR
Epi SG w/ Gibson Burstbuckers
Epi Casino
PRS Kit
Thinline Tele w/ SD 1/4 Lbs
Warmoth JM

Vox Nightrain
Marshall Class 5

Boss RC-20
DT EX-7
EHX Q-Tron +
EHX Big Muff Pi w/ Tone Wicker
Line 6 Echo Park

My PRS with SD P-Rails Build
#5
Have you opened up the Apogee Maestro software? Maybe you need to change the input type on the channel you're using. I assume you have mic on channel 1 and DI on channel 2 (that's what I do, anyway). Maybe the channel you think is a DI isn't set to DI at all. This is something they improved with the Duet 2 by adding a screen that shows you what each channel is set to. The original duet doesn't show you that on top, so you need to open its software to check.

Good luck!
Telecaster - SG - Jaguar
Princeton Reverb, Extra Reverb
P-Bass - Mustang Bass
Apogee Duet 2 - Ableton Suite