#1
I've been using my Samson StudioGT monitors both for recording and listening purposes, and have worked well for the two years I've had them, no problems.

Yesterday I turned them on and noticed sound wasn't going through them, and that I couldn't find Samson StudioGT in the devices list at all. They turn on, and my laptop observes that something was plugged in (via USB), but they don't "take" the sound, it just plays through the laptop speakers. For some reason they now come up as "UAC3556B."

I've tried using different USB ports, they all do the same thing. System Restore won't work because the latest restore point before these problems occurred was last December.

I'm running Windows 7 on a Dell laptop.

Any help would be greatly appreciated, thanks.
#3
Quote by 311ZOSOVHJH

My guess would be that something happened to the software drivers. Try reinstalling those and then rebooting your PC.


Which drivers? These monitors don't use software themselves, so I don't think there's anything there.

Sorry, I'm pretty technologically stupid.
#4
I know they don't use software per say but most everything that runs on a Microsoft based PC uses 'drivers' to tell the computer what to do with it. Even your mouse. I'm just saying, it wouldn't hurt to go to Samson website and see if there is such a thing. It is the only thing I can think of.