#1
I'm currently running a Digi Eleven Rack into the new ISP Stealth power amp, but due to me having a 16 ohm 4x12 cab, it's not near loud enough. That being said, I need a power amp that can push a 16 ohm mono 4x12 (peavey valveking cab with v30's) loud enough to handle shows. Price isn't a big issue so any suggestions would be helpful. Thanks guys!
#2
Hmmm, 30 tube watts will get a guitar into gig territory easily with a 4x12 cab. Are you sure all your connections are right and your output to amp is configured correctly? Digi rack is very flexible (complicated) so it's easy to set it up wrong. What kind of SPL do you need?

120db, 130db, 140db?
Last edited by Cajundaddy at Feb 18, 2014,
#3
Mesa 50/50 or 90/90.
Quote by 311ZOSOVHJH
Riffhog for President


Quote by Cathbard
There's no point apologising for your feet smelling when there's a 300lb gorilla in the room taking a crap on the couch.


Recognised by the Official EG/GG&A Who To Listen To List 2011
#4
Price isn't an issue?
Get a McIntosh power amp.

Allright, allright, let's be resonable.
Get whatever decent PA power amp you can find and make yourself a big XLR to 1/4" cable.
How 'bout an electro voice Q44 for example?
Name's Luca.

Quote by OliOsbourne
I don't know anything about this topic, but I just clicked on this thread because of your username :O
Quote by Cajundaddy
Clue: amplifiers amplify so don't turn it on if you need quiet.
Quote by chrismendiola
I guess spambots are now capable of reading minds.
#5
Quote by Cajundaddy
Hmmm, 30 tube watts will get a guitar into gig territory easily with a 4x12 cab. Are you sure all your connections are right and your output to amp is configured correctly? Digi rack is very flexible (complicated) so it's easy to set it up wrong. What kind of SPL do you need?

120db, 130db, 140db?


I believe I have all of my settings correct. I contacted Buck from ISP and he said that going into a 4x12 at 16ohms will only give me about 90 ohms SS. So i'm guessing that's my problem? Output wise I'm running an XLR to 1/4 cable from the Main output left of the 11r, into input 1 of the Stealth, then a stereo cable going into my cab. As for SPL, you'll have to forgive me, but i'm lacking in knowing that stuff haha
#6
Quote by AJG123
I believe I have all of my settings correct. I contacted Buck from ISP and he said that going into a 4x12 at 16ohms will only give me about 90 ohms SS. So i'm guessing that's my problem? Output wise I'm running an XLR to 1/4 cable from the Main output left of the 11r, into input 1 of the Stealth, then a stereo cable going into my cab. As for SPL, you'll have to forgive me, but i'm lacking in knowing that stuff haha


You should be using a speaker cable. Run from the Mono Bridged Output to the Input of your cab.
Spin 'round carousel when your horse isn't screwed in.

My band:
Fractured Instinct
(For fans of Death/Groove/Prog Metal)

Ibanez RGA42E
Ibanez S420
LTD H-301
Ibanez RG520
Peavey Predator USA
Douglas Grendel 725
Line 6 Pod HD500X
#7
Quote by Offworld92
You should be using a speaker cable. Run from the Mono Bridged Output to the Input of your cab.


I have no I idea why I said stereo, I am indeed using a speaker cable. Sorry for the error!
#8
Try using two separate XLR - Mono 1/4" cables, from 11R Left to ISP CH1 and from 11R Right to ISP CH2.

EDIT: Or just try two mono 1/4" - 1/4" from the Line Outs on the 11R.
Spin 'round carousel when your horse isn't screwed in.

My band:
Fractured Instinct
(For fans of Death/Groove/Prog Metal)

Ibanez RGA42E
Ibanez S420
LTD H-301
Ibanez RG520
Peavey Predator USA
Douglas Grendel 725
Line 6 Pod HD500X
#9
Quote by Offworld92
Try using two separate XLR - Mono 1/4" cables, from 11R Left to ISP CH1 and from 11R Right to ISP CH2.



I'll definitely give that a try and report back, thanks!
#10
Make sure you use the Bridged output. Otherwise you're only using half of your power.
Spin 'round carousel when your horse isn't screwed in.

My band:
Fractured Instinct
(For fans of Death/Groove/Prog Metal)

Ibanez RGA42E
Ibanez S420
LTD H-301
Ibanez RG520
Peavey Predator USA
Douglas Grendel 725
Line 6 Pod HD500X
#11
Quote by AJG123
I believe I have all of my settings correct. I contacted Buck from ISP and he said that going into a 4x12 at 16ohms will only give me about 90 ohms SS. So i'm guessing that's my problem? Output wise I'm running an XLR to 1/4 cable from the Main output left of the 11r, into input 1 of the Stealth, then a stereo cable going into my cab. As for SPL, you'll have to forgive me, but i'm lacking in knowing that stuff haha


I suspect something is not configured or connected right. 90W into a 4x 12 should be "Van Halen Concert loud"

SPL = Sound Pressure Level, expressed in decibels (db)

1watt into a 4x12 cab should be about 100db
20 watts into a 4x12 = 113 db (Rolling Stones Concert)
100 watts into a 4x12= 120db (Van Halen Concert)
1000 watts into a 4x12= 130db until the speakers catch fire (F-18 carrier takeoff)
#12
Quote by Cajundaddy
I suspect something is not configured or connected right. 90W into a 4x 12 should be "Van Halen Concert loud"

SPL = Sound Pressure Level, expressed in decibels (db)

1watt into a 4x12 cab should be about 100db
20 watts into a 4x12 = 113 db (Rolling Stones Concert)
100 watts into a 4x12= 120db (Van Halen Concert)
1000 watts into a 4x12= 130db until the speakers catch fire (F-18 carrier takeoff)



90 watts solid state is that loud? I didn't know that haha. Any suggestions configuration wise? I've gone over everything and can't seem to find the problem
#13
RTFM!

Haha, I don't own a Digi Eleven but I know they can be configured for a variety of output levels to feed different things like guitar amps, mixers, recording interface etc. A guitar amp setting or mixer setting would be way to low for a power amp input. You probably need a solid "+4 line level" output specific to feeding a power amp. This is 100x hotter than the signal you are feeding it now. From what you have said so far I am guessing the problem lies with the Digi configuration.

RTFM...
#14
Quote by Cajundaddy
RTFM!

Haha, I don't own a Digi Eleven but I know they can be configured for a variety of output levels to feed different things like guitar amps, mixers, recording interface etc. A guitar amp setting or mixer setting would be way to low for a power amp input. You probably need a solid "+4 line level" output specific to feeding a power amp. This is 100x hotter than the signal you are feeding it now. From what you have said so far I am guessing the problem lies with the Digi configuration.

RTFM...



LOL, I have countless time but as far as the manual goes, it's lacking configuration wise.
#16
Quote by riffhog
Mesa 50/50 or 90/90.


This.

Also, I remembered my local shop had this on their site:

http://www.nstuffmusic.com/p-986-mesa-boogie-simul-class-2ninety-power-amplifier.aspx?gclid=CMebsNPh1rwCFTIV7AodMm0Aog

Only other company I've used is Matrix, which is some pretty top end stuff.
I'm always screwing with my rig. Muh chilluns:
Warmoth NRFR strat JB/Jazz
Mesa Boogie Royal Atlantic, Diezel 2x12
Turbo tuner, J Cantrell wah, Alesis 3630
Green Rhino, Wampler Velvet, Strymon ElCap/Lex, Phase 45