#1
Okay, my guitars one tone knob wasn't functioning at all, so removed the pickguard, and cleaned the pot and it is working fine. However, now, when I am using my neck pickup, there is a significant amount of hum when I am using my neck pickup. When I touch the strings, the hum goes away. Is the ground connection on this pickup messed up? On the other pickups, they are perfectly fine with no hum.
Gibson Les Paul Traditional
Crate V33 212 Combo
DigiTech Whammy IV
Dunlop Crybaby
MXR Classic Distortion
Ibanez DE-7 Delay
Boss GE-7 Equalizer

#2
1st thing I would check would be to make sure you didn't know the ground wire from the neck p/u loose when you were messing with the pick-guard. You may have accidently pulled it off.
Guitars:
PRS Custom 24
Gibson Les Paul 60's Tribute
85' MIJ Strat
97' Snakepit Les Paul
LP Traditional 1960 Zebra
MIJ Tele
MIA Strat

Amps:
Silver Jubilee 2525
Peavey Ultra 112
Jet City JCA50H
66' Bassman
Pink Paisley Princeton RV
74' Vibro Champ
#3
Nevermind, seems to be working fine now after taking off pickguard and fiddling with it. odd.
maybe i will shield the pickup cavity
Gibson Les Paul Traditional
Crate V33 212 Combo
DigiTech Whammy IV
Dunlop Crybaby
MXR Classic Distortion
Ibanez DE-7 Delay
Boss GE-7 Equalizer

#4
It sounds like the wires were just not right (loose ground or something). If you leave it plugged into an amp (with volume kind of low) next time you're fiddling with wires, you might find the problem. You can fix the cavity but I don't think fiddling should make it stop buzzing...