#1
Right so my amp just switched itself off and there was a burning smell as I walked over to it. I'm a complete noob when it comes to amps, so just wondering if anyone knows what could be the cause of this? It won't switch back on D:

Also the amp can be set to 4/8/16 ohms, and it states that the stock setting for the internal speaker is 16 ohms, so does this mean (as I don't have any other cabs/speakers or whatever) it should be left on 16 ohms? It was on 4 for some reason, so I don't know if this had anything to do with it switching off.
Quote by DirtyMakik
Listen to this man, he's got Alex in his avatar, he knows his sh!t.

Quote by dubstar92
awesome avatar dude




Wow a signature
#2
How long did you run it with the impedance on 4?.....

That's not good. Not good at all. If you're lucky, you only blew your fuse. That's located in the back of your amp, and I believe you can get it out with a flat screwdriver. There should be replacements in your local music store.

Hopefully you didn't blow your transformer...(keep fingers crossed.)
Atmospheric dark metal w/ black and death metal influences:
(My Soundcloud page):

Pestilential Flood
#3
Ahhh I'm afraid it might have been on 4 for a while... fml. I have located the fuse (huge step, i know) but how do I check that, and the transformer? Oh god i'm such a noob when it comes to this.
Quote by DirtyMakik
Listen to this man, he's got Alex in his avatar, he knows his sh!t.

Quote by dubstar92
awesome avatar dude




Wow a signature
#4
there is a fuse on the back panel where the power chord goes and there are several in side the amp also.
2002 PRS CE22
2013 G&L ASAT Deluxe
2009 Epiphone G-400 (SH-4)
Marshall JCM2000 DSL100
Krank 1980 Jr 20watt
Krank Rev 4x12 (eminence V12)
GFS Greenie/Digitech Bad Monkey
Morley Bad Horsie 2
MXR Smart Gate
#5
I've got the fuse out, but I don't know what to look for to see if it has blown. There is no discolouration or anything noticeable really, not that I know what i'm looking for lol
Quote by DirtyMakik
Listen to this man, he's got Alex in his avatar, he knows his sh!t.

Quote by dubstar92
awesome avatar dude




Wow a signature
#6
is the metal filament intact? it will be broken if it is bad.

have you checked the fuses inside the amp?
2002 PRS CE22
2013 G&L ASAT Deluxe
2009 Epiphone G-400 (SH-4)
Marshall JCM2000 DSL100
Krank 1980 Jr 20watt
Krank Rev 4x12 (eminence V12)
GFS Greenie/Digitech Bad Monkey
Morley Bad Horsie 2
MXR Smart Gate
#7
After closer inspection it looks like it may have blown, there is tiny scorch mark on the side of it; heres an image just to clarify what i'm seeing http://imgur.com/jvAbe81

Also, no I haven't checked fuses inside the amp, not too sure where i'd find these. I just took that one out with a flathead as KailM stated.
Quote by DirtyMakik
Listen to this man, he's got Alex in his avatar, he knows his sh!t.

Quote by dubstar92
awesome avatar dude




Wow a signature
#8
Yeah the fuse is blown.
Only replace it with the same fuse
2002 PRS CE22
2013 G&L ASAT Deluxe
2009 Epiphone G-400 (SH-4)
Marshall JCM2000 DSL100
Krank 1980 Jr 20watt
Krank Rev 4x12 (eminence V12)
GFS Greenie/Digitech Bad Monkey
Morley Bad Horsie 2
MXR Smart Gate
#9
Ah okay thanks for your help, glad we figured this out before I dragged the amp all the way to a music store. Thanks again guys
Quote by DirtyMakik
Listen to this man, he's got Alex in his avatar, he knows his sh!t.

Quote by dubstar92
awesome avatar dude




Wow a signature
#10
When you power it back up look at the power tubes- if one or both start to glow bright red turn it off immediately.

Replace them and try again. There is no bias adjustment on your amp.
Quote by DeathByDestroyr
See, it's important that people clarify when they say "metal", because I pretty much always assume they are a Cannibal Corpse fanboi.
#11
I reckon changing the tubes is a bit out of my range of skill aha but thanks I will keep an eye on them. The fuses I ordered arrived today, but silly me I got the wrong size http://www.amazon.co.uk/250v-Quick-Blow-Glass-electrosmart%C2%AE/dp/B0036PIW9M/ref=sr_1_2?s=electronics&ie=UTF8&qid=1394068360&sr=1-2&keywords=250v+2a

Ultimate facepalm...
Quote by DirtyMakik
Listen to this man, he's got Alex in his avatar, he knows his sh!t.

Quote by dubstar92
awesome avatar dude




Wow a signature
#12
Tubes are easy. You just pull them out and put the new ones in. Just make sure the amp is switched off. Unless you go sticking metal objects in the tube sockets you can't electrocute yourself.

There is no bias adjustment on your amp.
Quote by DeathByDestroyr
See, it's important that people clarify when they say "metal", because I pretty much always assume they are a Cannibal Corpse fanboi.
#13
If you smelled stuff burning I'm thinking it's the component that burned up that led to the fuse blowing. Fuses themselves tend not to give off burning smells when they go. If the fuse is black and you sniff right up on it then maybe but from across the room? Sounds like more than a fuse went bad. Sorry to have a "negative" opinion and hope I'm wrong man! The amp isn't still under warranty is it?
Guitars:
Jackson Kelly KE3 - MIJ (Distortion/Jazz)
Jackson DKMGT Dinky (EMG 81/85)
ESP E-II Eclipse Custom (JB/'59)
ESP LTD EC-1001FR (EMG 81/60)
Fender MIM Strat

Amps:
Mesa/Boogie Dual Rectifier Roadster 212
Laney IronHeart IRT-Studio
Peavey Vypyr 30
Peavey ReValver Amp Sims
TOOOO many T.C. Electronic Pedals. . .
#14
Quote by metalmingee
If you smelled stuff burning I'm thinking it's the component that burned up that led to the fuse blowing. Fuses themselves tend not to give off burning smells when they go. If the fuse is black and you sniff right up on it then maybe but from across the room? Sounds like more than a fuse went bad. Sorry to have a "negative" opinion and hope I'm wrong man! The amp isn't still under warranty is it?


Hopefully it was just a tube red plating giving off the smell.
Quote by DeathByDestroyr
See, it's important that people clarify when they say "metal", because I pretty much always assume they are a Cannibal Corpse fanboi.
#16
hi everybody ,im searching for a new high gain amp for home practicing and few jams , whitch one is better ?
- engl gigmaster 15
- peavey 6505 +
- laney ironheart
#17
Quote by Allan_shimada
hi everybody ,im searching for a new high gain amp for home practicing and few jams , whitch one is better ?
- engl gigmaster 15
- peavey 6505 +
- laney ironheart


I'd make your own thread, these get cluttered when everyone replies to the TS and misses your post.

All 3 are good amps. What type of high gain are you after? List some bands that you like their sound and it might help.
Quote by DeathByDestroyr
See, it's important that people clarify when they say "metal", because I pretty much always assume they are a Cannibal Corpse fanboi.