#1
Hi all,

I just replaced the stock power tubes in my hughes and kettner tubemeister 18, with two SOVTEK EL84M.

When it's on standby, both tubes' filaments glow. But when I switch on the amp to play, only one tube has the bottom part glowing (both filaments are still glowing). The sound is still fine to me, and almost the same volume as before. But I can't turn up the volume so I'm not sure what happens then...

Would you think it's a tube problem? connection problem? or not a problem at all??....

Thanks
#2
A pic might help, but it is important to remember that even tubes of the same make won't glow the same.
I'm just a kickin' and a gougin' in the mud and the blood and the beer.
#3
If you're talking like a blue glow, no not all of them do that.
'93 Gibson LP Studio (498T/490R)-Ebony
'14 Gibson LP Standard (JB/Jazz)-Ocean Water Perimeter
Epi MKH LP Custom-7 (SD Custom Shop JB-7)-Ebony
+More

Maxon od808|Boss NS-2|Boss CE-5|
Line6 G55|Korg Pitchblack Pro

JVM 210h|1960a(V30/G12t-75)
#4
As long as the tube isn't white/foggy in any way, you're good.
Gibson RD Silverburst w/ Lace Dissonant Aggressors (SOLD)
Electra Omega Prime Ceruse
Fender Franken-Jag Bass

Amps and the like:
Laney VH100R
Seismic Luke 2x12
Dunlop 105Q Wah
Gojira FX 808
Line 6 M9
#5
well, it's an orange glow, just like normal light bulbs. Not white, not foggy, not blue not red, should I be happy about it? lol

the glow is like this
http://www.blakebryan.com/images/pictures/music/IMG_6188_640.jpg
(from google images)

and for the one that does not glow, it does not have the orange spot near the bottom


What if one of the tubes fails completely? How does it affect the amp or the sound??
#6
Quote by jszy
well, it's an orange glow, just like normal light bulbs. Not white, not foggy, not blue not red, should I be happy about it? lol

the glow is like this
http://www.blakebryan.com/images/pictures/music/IMG_6188_640.jpg
(from google images)

and for the one that does not glow, it does not have the orange spot near the bottom


What if one of the tubes fails completely? How does it affect the amp or the sound??


Your tubes are fine.

If one power tube goes out your amp will make a whole bunch of weird noises, the volume will cut in and out, and/or it just may not work at all. It will look like either the inside is burnt (like a blown fuse) or white and cloudy near the top of it.
Gibson RD Silverburst w/ Lace Dissonant Aggressors (SOLD)
Electra Omega Prime Ceruse
Fender Franken-Jag Bass

Amps and the like:
Laney VH100R
Seismic Luke 2x12
Dunlop 105Q Wah
Gojira FX 808
Line 6 M9
#7
The only colour to be worried about is red. If it sounds good, it is good.
Gilchrist custom
Yamaha SBG500
Telecasters
Randall RM100 & RM20
Marshall JTM45 clone
Marshall JCM900 4102 (modded)
Marshall 18W clone
Fender 5F1 Champ clone
Atomic Amplifire
Marshall 1960A
Boss GT-100


Cathbard Amplification
My band