#1
Went to play guitar today, switched on my amp and GT-100, first issue I noticed was when the foot pedal was set to minimum, the volume was not muted (with the pedal set to be used as a volume pedal). The volume would only drop down to an 8/10. Went to sweep the pedal up to max, and noticed about halfway through it's movement, the expression switch (under the pedal) would be activated. When the pedal is rocked back and forth, the expression switch is turned on and off, and I can be nowhere near even touching the switch. The switch is also inoperative. This is very weird, and very frustrating. It worked perfectly fine yesterday. And this would happen just shortly after the year warranty expired..
MY GEAR:
PRS SE Custom 24
Jackson DKA7
Gibson Explorer
MESA/Boogie Express 5:25
BOSS GT-100

BOSS TU-2
Dunlop Cry Baby Classic
BOSS NS-2
VOX Joe Satriani Ice 9 OD Pedal
VOX Joe Satriani Time Machine Delay Pedal
Ernie Ball Strings
V Picks
#2
Have you tried to re-calibrate the Exp-pedal yet? You can find this function on page 36 in the user´s manual: First push the system switch, then choose PDLCALIBRATION. There you set the Min. and Max. Position for the Pedal.
Push write to confirm each position.
Then activate the EXP switch by pressing the Pedal down.
If the EXP Pedal LED lights up, push write again. After this the EXP Pedal is re-calibrated.

Hope this solves your problem.
#3
That sucks. The manual should have basically what Hububu84 said.
My ME-80 does anyway.
#4
That was the first thing I tried. Even tried calibrating it where the minimum and maximum points weren't at the actually min and Max points of the pedals movement.
MY GEAR:
PRS SE Custom 24
Jackson DKA7
Gibson Explorer
MESA/Boogie Express 5:25
BOSS GT-100

BOSS TU-2
Dunlop Cry Baby Classic
BOSS NS-2
VOX Joe Satriani Ice 9 OD Pedal
VOX Joe Satriani Time Machine Delay Pedal
Ernie Ball Strings
V Picks
#5
Hm, too bad it´s not that easy to fix.
The only other thing I found in the manual is on page 37,38.
There is an option for the EXP pedal which switches the EXP-effect on/off when the Volume pedal is moved over middle position. For me, this sounds like the problem you described.
If nothing helps I would save the GT 100 patches to my computer and try a factory reset.