#1
I got a strat with single coils. The guitar is screened by the luthier.

I have Boss DS-2 and Retro-sonic chorus in my chain (guitar-ds2-retrosonic-combo)

When I turn on just DS-2 or the chorus, everything sounds fine.

When I turn them on all together I got a huge very loud noise and a bunch of unmanageable feedback.

What might be a problem here?
#2
How are the settings on the pedals?
How are you powering the pedals?
Name's Luca.

Quote by OliOsbourne
I don't know anything about this topic, but I just clicked on this thread because of your username :O
Quote by Cajundaddy
Clue: amplifiers amplify so don't turn it on if you need quiet.
Quote by chrismendiola
I guess spambots are now capable of reading minds.
#3
separately they sound fine.

Settings:

DS-2: level - 12, everything other on max
Chorus: level 12, speed - 9 o'clock.

I power them from one adaptor
#4
Try using less extreme settings and see if anything changes.

Also what do you mean by "I power them from one adaptor"?
You have a wall wart and you're daisy chaining them?
Name's Luca.

Quote by OliOsbourne
I don't know anything about this topic, but I just clicked on this thread because of your username :O
Quote by Cajundaddy
Clue: amplifiers amplify so don't turn it on if you need quiet.
Quote by chrismendiola
I guess spambots are now capable of reading minds.
#5
Will try today
Quote by Spambot_2


Also what do you mean by "I power them from one adaptor"?
You have a wall wart and you're daisy chaining them?


right. it is specially made for my pedalboard (amperage and voltage is right).

I also have holy grail reverb in the pedalboard but power it from separate power supply as the whole thing starts making a noise.