#1
i bought a samick jump20 guitar amp at a local shop. it's second hand and requires 110v while here in my country, the voltage is 220 so i use it with a transformer. everything was okay until one day that i accidentally turned the transformer off and heard a soft pop in the amp. as i turned on the transformer and the amp, the amp wouldn't power up anymore. i knew that the fuse blew so i bought new ones. the new ones i bought are shorter yet of the same rating so i thought that it was okay. i then used that on the amp and turned it on. luckily there was power in the amp now however there was no sound. i've noticed that when i replaced the fuse, the light that indicates power turns off slowly as opposed to the instant shutting of the light. what could be the problem here? any ideas and thanks is advance.
#2
Is there a single fuse in your amp?

'cause it sounds like you might just have substituted only one fuse out of more than one.
Name's Luca.

Quote by OliOsbourne
I don't know anything about this topic, but I just clicked on this thread because of your username :O
Quote by Cajundaddy
Clue: amplifiers amplify so don't turn it on if you need quiet.
Quote by chrismendiola
I guess spambots are now capable of reading minds.
#4
There is a very slight possibility that you might have fried your speaker.

If you can and you know how to do it, test it with whatever you've got to test speakers with.

If you can't, and the amp has an fx loop, then try plugging a pair of headphones into the fx send with the gain set very high (just to be sure start from zero, though you'll probably have to turn it up a lot), play into the amp with the guitar and see if anything comes out of the headphones.

If you can't test the speaker and the amp doesn't have an fx loop, getting a new amp is the most convenient solution I can think of.
Name's Luca.

Quote by OliOsbourne
I don't know anything about this topic, but I just clicked on this thread because of your username :O
Quote by Cajundaddy
Clue: amplifiers amplify so don't turn it on if you need quiet.
Quote by chrismendiola
I guess spambots are now capable of reading minds.
#5
Unfortunately though, the amp doesn't have an effects loop. i guess that i should take it to a technician. but any ideas would still be accepted because i don't really have enough money to have it fixed much more to buy a new one.
#6
Solid state amp, yes? My gut tells me that you've blown an output transistor. That has lowered the drain on the supply and is why the power indicator takes longer to turn off. This is just a guess. If it was mine I'd be pulling them out and testing them.
Gilchrist custom
Yamaha SBG500
Telecasters
Randall RM100 & RM20
Marshall JTM45 clone
Marshall JCM900 4102 (modded)
Marshall 18W clone
Fender 5F1 Champ clone
Atomic Amplifire
Marshall 1960A
Boss GT-100


Cathbard Amplification
My band
#7
Quote by Cathbard
Solid state amp, yes? My gut tells me that you've blown an output transistor. That has lowered the drain on the supply and is why the power indicator takes longer to turn off. This is just a guess. If it was mine I'd be pulling them out and testing them.

What exactly is an output transistor? and yes it is solid state.
#8
They're what drives the speakers.
Gilchrist custom
Yamaha SBG500
Telecasters
Randall RM100 & RM20
Marshall JTM45 clone
Marshall JCM900 4102 (modded)
Marshall 18W clone
Fender 5F1 Champ clone
Atomic Amplifire
Marshall 1960A
Boss GT-100


Cathbard Amplification
My band
#10
where was the fuse you replaced? sometimes there is a second HT fuse in the chassis.

to test the speakers run a meter across the terminals see if the is continuity. takes 30 sec.

i really think that something got fried though.
WTLT 2014 GG&A

Quote by andersondb7
alright "king of the guitar forum"


Quote by trashedlostfdup
nope i am "GOD of the guitar forum" i think that fits me better.


Quote by andersondb7
youre just being a jerk man.



****** NEW NEW NEW!
2017-07-07 2017-07-07 Update and a Chat On Noise Constraints *** NEW FRIDAY 7/7
2017-04-13 RUN AWAY from COMPUTERS!!! TCE? RANT ALERT!!!
2017-03-02 - Guitar Philosophy 1001- Be Prepared For the Situation (Thursday 2017-03-02)
2017-02-21 How to Hot-Rod the Hell of your Stratocaster for $50! (Tuesday 2017-2-21)
Resentments and Rambling from a Guitar Junkie
---> http://trashedengineering.blogspot.com/
#11
The fuse i replaced is near the power switch. and i highly believe that that is the only one. there's another space for adding an extra fuse on the board. i guess that's for changing the schematics' but there isn't anything installed on that.
#12
Quote by trashedlostfdup
where was the fuse you replaced? sometimes there is a second HT fuse in the chassis.

to test the speakers run a meter across the terminals see if the is continuity. takes 30 sec.

i really think that something got fried though.

It's SS, no HT fuse - no HT. I'd test the speaker anyway because it's a load but it takes longer for the power supply to discharge so something's fried inside the amp. Removing the speaker load wouldn't make much difference to that I wouldn't think. I'd test it with a multimeter though just for peace of mind, but dollars to donuts it's something bigger and nastier.
Gilchrist custom
Yamaha SBG500
Telecasters
Randall RM100 & RM20
Marshall JTM45 clone
Marshall JCM900 4102 (modded)
Marshall 18W clone
Fender 5F1 Champ clone
Atomic Amplifire
Marshall 1960A
Boss GT-100


Cathbard Amplification
My band
#13
i'm really clueless now. don't really know what to do now. guess i should take it to someone competent enough.
#14
Quote by Cathbard
It's SS, no HT fuse - no HT. I'd test the speaker anyway because it's a load but it takes longer for the power supply to discharge so something's fried inside the amp. Removing the speaker load wouldn't make much difference to that I wouldn't think. I'd test it with a multimeter though just for peace of mind, but dollars to donuts it's something bigger and nastier.


:facepalm; (myself) ****. good luck OP.
WTLT 2014 GG&A

Quote by andersondb7
alright "king of the guitar forum"


Quote by trashedlostfdup
nope i am "GOD of the guitar forum" i think that fits me better.


Quote by andersondb7
youre just being a jerk man.



****** NEW NEW NEW!
2017-07-07 2017-07-07 Update and a Chat On Noise Constraints *** NEW FRIDAY 7/7
2017-04-13 RUN AWAY from COMPUTERS!!! TCE? RANT ALERT!!!
2017-03-02 - Guitar Philosophy 1001- Be Prepared For the Situation (Thursday 2017-03-02)
2017-02-21 How to Hot-Rod the Hell of your Stratocaster for $50! (Tuesday 2017-2-21)
Resentments and Rambling from a Guitar Junkie
---> http://trashedengineering.blogspot.com/