#1
I have a Laney Ironheart 60 Watt head running into a Mesa Boogie 4x12 half open Cab. I cannot run my head over say 12 o'clock without the speakers Sounding like they are gonna give out, it almost sounds like they cannot handle the bass. Even worse if I block off the top portion of the cab. Is this Typical of this Speaker? The bottom Two are EVM12l's And i know that they should be able to handle the bass. Should I just replace all 4 speakers? This is a 1980's Mesa cab......
#2
Both of those speakers are more than adequate. Maybe one of them has blown a cone? You should be able to see it.
Gilchrist custom
Yamaha SBG500
Telecasters
Randall RM100 & RM20
Marshall JTM45 clone
Marshall JCM900 4102 (modded)
Marshall 18W clone
Fender 5F1 Champ clone
Atomic Amplifire
Marshall 1960A
Boss GT-100


Cathbard Amplification
My band
#3
The speakers do not appear to be blown....I'm not sure at lower volumes its fine, but at higher volumes it seems like under heavy palm muting the speakers just cannot handle it. Maybe replace the top two with 2 more ev12l's? The sound does not stay tight, it gets really flabby, and this is with my resonance Controll all the way off.
Last edited by pandamidian at Sep 11, 2014,
#4
If one isn't blown, I'd look elsewhere for the problem. Maybe tubes. Both of those speakers are kickass.
Gilchrist custom
Yamaha SBG500
Telecasters
Randall RM100 & RM20
Marshall JTM45 clone
Marshall JCM900 4102 (modded)
Marshall 18W clone
Fender 5F1 Champ clone
Atomic Amplifire
Marshall 1960A
Boss GT-100


Cathbard Amplification
My band
#5
I played though another cab, and it sounded fine at the volume that mine was breaking up badly at. very tight and defined. That's why I'm thinking its the speakers. the other cab was a Madison 4x12 cab. Is it possible that the speakers are just going out, they are 30 years old?
#6
Maybe. Your task is to identify which one is actually problematic.
Gilchrist custom
Yamaha SBG500
Telecasters
Randall RM100 & RM20
Marshall JTM45 clone
Marshall JCM900 4102 (modded)
Marshall 18W clone
Fender 5F1 Champ clone
Atomic Amplifire
Marshall 1960A
Boss GT-100


Cathbard Amplification
My band
#7
I guess I can rig each one up to a jack, play through them each alone and see where the issues lie. So the c90's should handle extreme low end chugging okay without breaking up? Im wondering if its the range, not the power causing the issue.
#8
Yes, that's how to do it. Make sure you select the correct impedance on the amp when you do it. It won't be the type of speaker, one or more is ****ed.
Gilchrist custom
Yamaha SBG500
Telecasters
Randall RM100 & RM20
Marshall JTM45 clone
Marshall JCM900 4102 (modded)
Marshall 18W clone
Fender 5F1 Champ clone
Atomic Amplifire
Marshall 1960A
Boss GT-100


Cathbard Amplification
My band
#9
c90s are (more or less) classic leads, aren't they? if so, as cath says, that shouldn't be the problem.
I'm an idiot and I accidentally clicked the "Remove all subscriptions" button. If it seems like I'm ignoring you, I'm not, I'm just no longer subscribed to the thread. If you quote me or do the @user thing at me, hopefully it'll notify me through my notifications and I'll get back to you.
Quote by K33nbl4d3
I'll have to put the Classic T models on my to-try list. Shame the finish options there are Anachronism Gold, Nuclear Waste and Aged Clown, because in principle the plaintop is right up my alley.

Quote by K33nbl4d3
Presumably because the CCF (Combined Corksniffing Forces) of MLP and Gibson forums would rise up against them, plunging the land into war.

Quote by T00DEEPBLUE
Et tu, br00tz?
#10
im not saying that speaker sucks, I'm just wondering if its just a damaged or somethings wrong, it farts out to earlier i think....or maybe im pushing the EQ too hard through the fx loop, too much bass? to low mids? who knows.
#11
^ no worries. i hope you get it sorted.
I'm an idiot and I accidentally clicked the "Remove all subscriptions" button. If it seems like I'm ignoring you, I'm not, I'm just no longer subscribed to the thread. If you quote me or do the @user thing at me, hopefully it'll notify me through my notifications and I'll get back to you.
Quote by K33nbl4d3
I'll have to put the Classic T models on my to-try list. Shame the finish options there are Anachronism Gold, Nuclear Waste and Aged Clown, because in principle the plaintop is right up my alley.

Quote by K33nbl4d3
Presumably because the CCF (Combined Corksniffing Forces) of MLP and Gibson forums would rise up against them, plunging the land into war.

Quote by T00DEEPBLUE
Et tu, br00tz?
#12
Looks like ill be replacing all 4 speakers, none of them hold up to the tone i want out of the amp, but if i plug in another cab, it sounds just fine....is it possible its the cab??? I'm sure evm12ls will hold up to anything i throw at it...yes? 300watt version.