#1
I just got the newest edition of ASIO4ALL and managed to get my soundcard to get a ridiculously low latency in working with my Focusright 2i4. I did this so that I could take my amp and cab out of the equation tonally speaking and hear what it actually is recording (e.g. what others will hear after I record and edit a piece).

The problem that has arisen now is that I can either use ASIO4ALL and ONLY output what I'm playing on the guitar, OR my normal windows sound output via the soundcard. I can no longer play both at the same time in order to use a tab program playback a tab while I work it out on the guitar WHILE actually playing the guitar through my DAW.

My DAW is Reaper, I use VST effects, amps, cab sims etc...

Does anyone know how to setup ASIO4ALL within or outside of Reaper while also keeping my windows sound output so I can run my tab program (guitar pro)? (Windows 8.1, Xonar 7.1 sound card)

I am using the analog outputs of the card, no digital outputs used.


----------------------------


Edit:

I've noticed that if I deselect "ASUS Xonar DSX Audio Device, and restart my media player or guitar pro I can now play normally, but I don't get audio output from reaper.

Seems to be something going on here. I know I don't have any of the digital options on, in fact all Ihave running the main ASUS Xonar DSX Audio Device drop down, ASUS Xonar DSX Audio sub-drop down is active, and under that is the In and Out, only the Out is active. Then I have the Scarlett 2i4 USB Drop Down active, and only the In is active under that.

Buffer is 512. I get rediculously low 2.3 latency with this though... less than the official drivers for the DI. Lol. Which is why I want to use ASIO4ALL V2.12.

Any ideas on how to force the ability to use ASIO4ALL AND have normal sound output from my other windows softwarez?
"grateful is he who plays with open fingers" - Me

┌∩┐(◣_◢)┌∩┐

DO NOT CLICK HERE!
Last edited by Outside Octaves at Oct 21, 2014,
#2
Quote by Outside Octaves
I can no longer play both at the same time in order to use a tab program playback a tab while I work it out on the guitar WHILE actually playing the guitar through my DAW.
I never managed to do that, and I am convinced you can't do that.

I've read that you just need to set up win and your daw to use the same in/out sampling rate and resolution for it to work.

Don't really know about that myself, but it's easy so you may want to try that yourself.
Name's Luca.

Quote by OliOsbourne
I don't know anything about this topic, but I just clicked on this thread because of your username :O
Quote by Cajundaddy
Clue: amplifiers amplify so don't turn it on if you need quiet.
Quote by chrismendiola
I guess spambots are now capable of reading minds.
#3
Welp, with a lot of poking around and about, I found out how to do it.

Just needed the latest ASIO4ALL, and a little program called VAC with the kernal Stream Audio
Repeater.

It's still a bit funky, but I can get audio out of any sources as long as I stop the audio repeater program and start it back up if I want to load another audio program. Not perfect, but works for now I guess .

So it's not impossible after all... just a bit wanky.
"grateful is he who plays with open fingers" - Me

┌∩┐(◣_◢)┌∩┐

DO NOT CLICK HERE!
#4
How did you get the latency so low with ASIO4ALL, and how come you aren't using the 2i4 drivers?
I've got the same interface, and still having some troubles using it.
#5
Well, today interestingly enough it's fudged up somewhere out of the blue and I had to put my buffer up to 512 which puts me back into the 16ms range, but I just use reaper and set the buffer (or what they call block size) to 224 and check the box next to it . This is done inside of the Audio>Device settings tab. I also request 96k and check that box.

I've got to figure out what caused it to suddenly start chopping up my sound like it has too small a buffer even though earlier this morning and all throughout my time having it + asio4all I had it set to 224... now on 512, but yea...wtf o.0 .

I wasn't using the 2i4 drivers because of the 18ms response time... compared to asio4all getting 2.6 or whatever... but now it doesn't seem to matter with this issue cropping up. Dunno what happened.
"grateful is he who plays with open fingers" - Me

┌∩┐(◣_◢)┌∩┐

DO NOT CLICK HERE!
Last edited by Outside Octaves at Dec 30, 2014,
#6
I don't know if this will work but it may have something to do with the exclusivity settings for your sound devices.

If you right click on the volume icon in the system tray > playback devices > select the speakers or whatever and hit properties > advanced......Under exclusive mode there are two options, try messing with those.

What you want may not be available since Windows sees your soundcard (or onboard audio), it sees the focusrite as another sound device, and then it also is using the ASIO drivers. I'm not sure if you can send all output to one device or not. Basically you have 3 driver sets running.

I had a nightmare of a time getting Windows to use my M-Audio and ASUS Xonar at the same time, as Windows sees them as two soundcards basically.