#1
I have got a zoom g9.2tt, which was doing fine for about a year, but recently it ran into trouble. The unit doesnt pick up any input signal and there is no sound from the unit. I have checked all accessories, jack, I/O, adapter, Amp all are fine. The unit gets powered on but doesn't pick any signal, even the tuner doesn't show any indicator.

Anyone, familiar with this type of problem and knows to fix it, kindly suggest me what needs to be done. Your effort will be appreciated.

Regards.
#2
Not much you can do but take it apart and hope that the input jack is broken or a bad solder joint. Because that's going to be the easiest fix.
#3
That bad huh, so there is no twiking of knobs that could fix it huh!! Well, it's gonna be complicated...I will give it a try ......wat could be the cause of it!!
#4
Quote by basezero
......wat could be the cause of it!!
Broken input jack or bad solder joint.
#5
Damn!! will pray with my fingers crossed. Guess opening the unit is gonna be complicated. Is there any videos or instruction on how to open the unit. As I am afraid that I might make things worse if I f**k up fixing later. Also will the unit sound better if I change the valves with some better ones like groove tubes GT-12AX7-C and GT-12AX7-R2 preamps since I will be opening the unit anyways.
#6
Unlikely that it's worth fixing if the problem is the digital electronics. So I wouldn't worry too much. People have reported that changing the tube on the G5 makes a difference so give it a try.
#7
Hmmm, lets see if could grab the valves at a reasonable price then I might consider it. Thank you for the advice. Do you have a G9 as well??
#9
Do u by any chance have got good collection of patches for g9 or is there a good site for one?? I play progressive metal, hardcore metal but now I have started liking djent. btw I opened up my zoom g9 bt dun kno where to start. Do I have to open up all the CB to look at the input port??
#11
Don't have any patches saved for the G9. I only had mine for a while. I'm afraid you need to get someone to help you with figuring out your problem. You need to look at the solder joints and check continuity between the input cable and the traces/solder pads on the circuit board.
#13
You're welcome. Fixing a problem like this generally entails stripping it down and looking for any visual problems. Even cracked solder joints can be difficult to see without a magnifying glass. At the minimum you need a soldering iron and multimeter to attack a job like this.
#14
Have you tried using a different instrument cable? (I'm guessing you have but you never mentioned it) you could try doing a factory reset on it as well.
#16
Quote by diabolical
Not sure how it is wired with the token tube but it is possible that it went down, would look there first.

No idea what is token tube I could post a picture the inside picture of the unit if like to check it out.


Yes, I tried it will different cables but still the problem persist. Factory reset also doesn't help.
#18
I think the tuner not working suggests the problem is not the tube. On the G5 the tube is at the end of the audio chain. Even after the USB audio interface. I.E. the tube has no effect on recorded audio.

The Digitech RP has an issue of powering up but delivering no sound if the AC power supply is replaced with a DC version. But I'm guessing if the OP changed power supplies that would have been mentioned.
Last edited by fly135 at Feb 13, 2015,