#1
hey guys Thanks for the help so for but I need a little more!

Okay so I Recently got into the tube game here and I'm pretty new to guitar.. about a year of playing. I recently bought a krank rev jr pro and replaced all the 12AX7 tubes but have yet to replace the power tubes. I have the head hooked into my fender FM212r speakers. I have it all wired correctly, checked my work with a DVOM.

Okay so my gear is a Schecter Stlealth C-1 with Ernie Ball Heavey top skinny bottoms running into a Krank Rev Pro jr 20W running to my stock Fender FM212R speakers.

Alright so I replaced all the 12AX7 tubes because of the tapping trick. there was 2 Ruby ones which I figured were OEM and there was 3 JJ ECC 83S. I noticed the previous owner stated that he replaced all of them.... But when I got into it, I found that the Phaser or inveter? tube wasn't replaced and there was one also under a metal cap that wasn't replaced, Witch I think might have been part of the Distortion channel.

Later I found out that any tube placed in the socket of the one with metal retaining cap over it.. sounds like a bad tube. it tings and you can here it night and day through the speakers.. Although some sounded worse then other I replaced all 5 of them with Electro Harmonix. Sounds better so I'm happy with this. But again they all ting loud and sound micro-phonic.

The reason why I haven't replaced the Power tubes yet is because.. 1, they are quite and don't sound "micro-phonic"and 2, no really bad performance etc. volume problems or noise issues.. there Sovtec 5881 tubes witch I also believe that are OEM from 2008

All the info so far I know about this subject I've researched on youtube and the interwebs. I have a degree in basic electronics so I understand most of it.. but please if I am wrong with anything let me know. This is how I learn and I love teaching! so I always give back the retained info.

Now for my actual questions.. I wanted to give you guys some in site one what I've chased already and I know its getting long, but I've been scratching my head over this forever! well a week but yeah..

1, So when I play, its usually tuned to drop D but has been in drop C lately. With the gain up close to full and the master up pretty loud but no were near maxed.. I get a horrible ringing noise through the 4th open D string while single string plucking. Its bad and usually kills the fun of song covers. The weird thing is, is that it doesn't start right away with this noise, usually comes on shortly after I start playing.. Its always there and when I've got a little ways into playing without the noise everything sounds really good. when its there it doesn't so much.

The noise kind of sounds like a sharp ring, kinda like moving your fingers up and down the strings ever so slightly or the pick is moving up or down. Its hard to explain and I cant seam to get it on video. but a bell ring.

I've tried this guitar on my fender amp hooked up to the speakers and its seems to do it was well. but sounds really good on both amps clean channel. So now I'm wondering if it is the guitar its self, but couldn't find much info on this subject.

Is there anything that could cause this in the guitar its self. It doesn't create feedback or anything. So I'm really stumped. could it bee the amp?

2. I've heard once a radio station coming through the Krank head and noticed that my cellphone creates a frequency or chirping like old computer speakers. Is this normal? my guitar cables are good. found out it might be a ground issue. Also could having electronics like a cellphone and computer all on the same small desk cause sound clarity issues?


3. How come in this socket that I mentioned above make every tube sound like it is micro phonic? does it have something to do with the distortion channel or maybe the the socket its self? but even if I tap on other tubes that one rings and tings. I have a picture here to show the layout of the tubes.

http://powerdragon-powerdragon.blogspot.com/2009/12/krank-revolution-junior-pro.html


Any help will be great! I always appreciate it!
Last edited by thenewguy330 at Mar 3, 2015,
#2
I have a Krank 1980Jr and I haven't had any issues. Stock they have EHX 12ax7's and Sovtek 5881. You can try swapping the power tubes out, but be careful, there is only a little room so only a few brands/types of tubes will fit. if that doesn't work time to let a tech look at it
2002 PRS CE22
2013 G&L ASAT Deluxe
2009 Epiphone G-400 (SH-4)
Marshall JCM2000 DSL100
Krank 1980 Jr 20watt
Krank Rev 4x12 (eminence V12)
GFS Greenie/Digitech Bad Monkey
Morley Bad Horsie 2
MXR Smart Gate
#4
Quote by bucketomeat
Have the tubes been biased?

It is a self biasing amp
2002 PRS CE22
2013 G&L ASAT Deluxe
2009 Epiphone G-400 (SH-4)
Marshall JCM2000 DSL100
Krank 1980 Jr 20watt
Krank Rev 4x12 (eminence V12)
GFS Greenie/Digitech Bad Monkey
Morley Bad Horsie 2
MXR Smart Gate
#5
What is the rated impedance of your 212 cab? If it's 4 ohm and the min impedence on the crank head is 8 ohm this could cause problems.
"Your sound is in your hands as much as anything. It's the way you pick, and the way you hold the guitar, more than it is the amp or the guitar you use." -- Stevie Ray Vaughan

"Anybody can play. The note is only 20 percent. The attitude of the motherfucker who plays it is 80 percent." -- Miles Davis

Guthrie on tone: https://www.youtube.com/watch?v=zmohdG9lLqY
#6
Thanks for the reply rob.

I almost think it has something to do with that tube socket. because it doesn't do it on the kleen channel, and doesn't do it with a pedal through the kleen channel. I should take it apart and look for cold solders.

Been playing it sense i posted this post and got me thinking.
and if I send it to a tech and they fix it.. Ill feel like I failed!

again all tubes tried in that socket doesnt sound right. they all ting really loud.

It is in series. 16 ohms. my amp is set to 16 aswell
#7
Quote by Cajundaddy
What is the rated impedance of your 212 cab? If it's 4 ohm and the min impedence on the crank head is 8 ohm this could cause problems.

I've never tried, but Krank did say if you switch to 8ohms you can safely run a 4ohm load on their forums. (*before they went out of business)
2002 PRS CE22
2013 G&L ASAT Deluxe
2009 Epiphone G-400 (SH-4)
Marshall JCM2000 DSL100
Krank 1980 Jr 20watt
Krank Rev 4x12 (eminence V12)
GFS Greenie/Digitech Bad Monkey
Morley Bad Horsie 2
MXR Smart Gate
#8
Quote by thenewguy330
Thanks for the reply rob.

I almost think it has something to do with that tube socket. because it doesn't do it on the kleen channel, and doesn't do it with a pedal through the kleen channel. I should take it apart and look for cold solders.

Been playing it sense i posted this post and got me thinking.
and if I send it to a tech and they fix it.. Ill feel like I failed!

again all tubes tried in that socket doesnt sound right. they all ting really loud.

It is in series. 16 ohms. my amp is set to 16 aswell

you can contact Tony Krank with questions and request a schematic of the amp. He is still servicing all Krank and Stiff amps but his new company is called Revolution Amps


Address
500 N. 56th Street
Suite 14
Chandler, AZ 85226


Contact
general@revolutionamps.com
480-207-6731
http://revolutionamps.com


this has the sizes of all the new production 6L6 tubes on it so you can see what can and can not fit. I highly suggest you actually measure your spacing because I have found the Jr series all differ a bit.
www.tubesandmore.com/tech_corner/6l6gc-comparison-current-made-tubes
2002 PRS CE22
2013 G&L ASAT Deluxe
2009 Epiphone G-400 (SH-4)
Marshall JCM2000 DSL100
Krank 1980 Jr 20watt
Krank Rev 4x12 (eminence V12)
GFS Greenie/Digitech Bad Monkey
Morley Bad Horsie 2
MXR Smart Gate
Last edited by Robbgnarly at Mar 4, 2015,