I put in the track "Floods" by Pantera for the purpose of covering it with overdubbed guitar and what have you.

Here is my problem - No matter what I set the BPM/Metronome to, it DOES NOT ever sync up to the song. Even when I hold shift and drag the songs beginning to an appropriate point for it to sync up to every beat/measure.

Am I doing something wrong? How does one perfectly sync up a metronome to an already mixed/produced song such as a Pantera song like this? I've tried BPM's 59-65 and 115-125 and nothing syncs up.

I also hate how once the track is already in and you change BPM, the whole track changes speed, so I have to delete the track, set bpm, start trying again.
I think that was recorded in analog and not played with a click, one of the reasons why Pantera were so good, they were really tight as a band and didn't need to track down to a click.

You can go in sections and try something like tap to tempo and see if it first. I'd say look for hits on the audio file where there is a kick and snare, that'd should be your 1 and 2 or 1 and 3, depending on how it is played.

Look up this Reaper Tempo Mapping tutorial:
Thank you sir I shall mess around with this function. I'm trying to get more and more used to Reaper, depending on how patient I am.
I've noticed that if you adjust the tempo of a song AFTER you've imported a track it gets weird. try setting the tempo to the correct BPM in reaper before you drag the mp3 in (assuming that's how you're doing it)
To fix it speeding up and slowing down I've found that right clicking the stem and going to Item Settings -> Set Item Timebase to Time works pretty well.
But yeah, trying to sync to songs that haven't been recorded to a click is a pain.
Quote by Jackolas
edgespear, driving great ideas again. Sir, you pwn.

Guitar: Epiphone Les Paul, PRS SE Floyd Custom 24 Floyd Amethyst
Amp: Peavey 6505, Eleven Rack