#1
Hey guys,
I have a Fender Frontman 15R that I used a couple of times and was just sitting around since.
Today I turned it on just to see if it's still works and it makes an unbearable and very loud screeching sound, I'm not talking about the usual humming noises an amp makes, it's a really, truly a horrible sound.
I've tried turning all the knobs down, replaced the power fuse and opened it up to see if something came loose but everything really looks fine and it just looks like new inside, does anyone has an idea what it could be and how to fix it?
Last edited by Ryushi at Oct 1, 2015,
#2
Here's some stuff to check
https://www.ifixit.com/Wiki/Fender_Frontman_15r_Troubleshooting

Honestly, it's a sub 100 dollar amp. It's probably not worth fixing. You could probably find a comparable amp used for even cheaper. Or, maybe it's time to upgrade just a bit.
Harmony: Stratocaster
Alvarez: F-200
Schecter: Omen 6
Fender: BXR-60
Dean: Metalman Z Bass (Betty)
Egnator: Tweaker 15
Pearl: Maximum
ESP/LTD: EXP-300
Custom: Harley Quinn Bass
Custom: TK-421 Explorer
A steadily growing supply of pedals
#3
Thanks I'll check this link maybe I missed something when I opened it up ,it's a cheap amp I bought years ago, I don't play very often so it was just sitting around, I'll probably replace it but I like try fixing stuff before I throw them.
#4
Try headphones, too. Maybe you can still use it for practice.
Harmony: Stratocaster
Alvarez: F-200
Schecter: Omen 6
Fender: BXR-60
Dean: Metalman Z Bass (Betty)
Egnator: Tweaker 15
Pearl: Maximum
ESP/LTD: EXP-300
Custom: Harley Quinn Bass
Custom: TK-421 Explorer
A steadily growing supply of pedals
#5
I'd try contact cleaner in all the pots and jacks.
Guitars:
Jackson Kelly KE3 - MIJ (Distortion/Jazz)
Jackson DKMGT Dinky (EMG 81/85)
ESP E-II Eclipse Custom (JB/'59)
ESP LTD EC-1001FR (EMG 81/60)
Fender MIM Strat

Amps:
Mesa/Boogie Dual Rectifier Roadster 212
Laney IronHeart IRT-Studio
Peavey Vypyr 30
Peavey ReValver Amp Sims
TOOOO many T.C. Electronic Pedals. . .
#6
It's making that noise even with with my guitar unplugged, I'll try cleaning everything with contact cleaner and take it apart again tomorrow to see if I missed something, if everything fails I'll probably buy a replacement.
Last edited by Ryushi at Oct 1, 2015,
#7
I have a Peavey Audition 20 from the 80's that just sounded like garbage and the speaker would only fart. Contact cleaner on everything and it's good to go. Give it a shot - some corrosion may be causing some grounding issues.

And I'm talking about electrical contact cleaner, not eye contact lense cleaning solution :-)
Guitars:
Jackson Kelly KE3 - MIJ (Distortion/Jazz)
Jackson DKMGT Dinky (EMG 81/85)
ESP E-II Eclipse Custom (JB/'59)
ESP LTD EC-1001FR (EMG 81/60)
Fender MIM Strat

Amps:
Mesa/Boogie Dual Rectifier Roadster 212
Laney IronHeart IRT-Studio
Peavey Vypyr 30
Peavey ReValver Amp Sims
TOOOO many T.C. Electronic Pedals. . .