#1
Hi there,

I've tried searching the internet for my specific issue but I fail to find information that specifically addresses what I'm experiencing. Right now I'm on an up-to-date MacBook pro 2009 13" with upgraded RAM (4g) and brand new hard drive [SS 480g]. My interface is an m-audio fast track pro. I understand its not the best interface, however when I use it directly through Guitar Rig 5 I have no major issues with sound quality or latency - 99% clear tone and the various gain levels adjusted appropriately to remove clipping. Unfortunately, when I try and use Studio One or even other DAWs like REAPER I use the same aggregate device setup with the audio interface and built-in output (have tried other arrangements too) but the dry guitar signal sound I get is this distorted/bit-crushed sound with an echo. I have not figured a way to reduce this at all. If it has something to do with buffer settings I'm not too familiar with how to properly adjust them. Please help! Thank you
#2
Have you tried raising the buffer size in the settings of these DAWs you're using?
Name's Luca.

Quote by OliOsbourne
I don't know anything about this topic, but I just clicked on this thread because of your username :O
Quote by Cajundaddy
Clue: amplifiers amplify so don't turn it on if you need quiet.
Quote by chrismendiola
I guess spambots are now capable of reading minds.
#3
Definitely sounds like a buffer issue to me. Like spam said, you should try raising it. This will increase latency. The reason you probably hear a delay is because you might be hearing your guitar dry sound that is going through your interface preamp and the "record monitoring" sound, which has gone through your daw and then back through your preamp (this one will be delayed and also have the crushed sound to it due to your buffer). You need to set your mix on your interface to turn off that dry signal so you only hear the "record monitor" signal
Quote by suckmahnuts
Watterboy, I love you.

Quote by davrossss
You are now my favourite person on UG.....You write cool shit.

Quote by wannabestoner69


#4
Thanks guys. I just find it strange that with the same exact setup in guitar rig I have no problems. My headphones are plugged into the computer and not the interface. By buffer rate do you mean the number/value that is like 44000?
#5
Quote by danielsharps
Thanks guys. I just find it strange that with the same exact setup in guitar rig I have no problems. My headphones are plugged into the computer and not the interface. By buffer rate do you mean the number/value that is like 44000?


No, i believe thats the sample rate that youre refering to. What you want is called "buffer size" like spambot said, and by default it is usually around 500 samples. "Samples" is the unit for it; in reaper it sometimes shows you how much MS latency your buffer size will yield, but it depends on the driver youre using. With ASIO4all, i usually find I cant set the buffer lower than 400ish, or else i start getting that crazy bit crushing sound. With my RME babyface driver, i can get the buffer size down to 64ish (if there are barely any vsts in use) with an occasional skip. Usually 200ish is safe from errors and the latency still isnt really noticeable
Quote by suckmahnuts
Watterboy, I love you.

Quote by davrossss
You are now my favourite person on UG.....You write cool shit.

Quote by wannabestoner69


#6
You mention aggregate device, no way to drop that and try from scratch? I think there might be something funky happening there. Been a while since I've worked on Mac but sounds like you have some kind of bitrate mismatch maybe, something with the clock sync on the audio interface and the software is not working right or maybe the bitrate settings in the DAW are wrong.

How about looking up the sound driver settings? It should be in the Mac menu on the top left, my UA4FX showed up there.

Maybe check with M-Audio on this or at least read up how to control their driver from the OS menu. I think it might be in Finder under Utilities.
#7
You folks are amazing! Thanks for clarifying what values are used for the buffer. Right now it's defaulted to 512 I believe (at work right now). Guitar rig forces me to use the aggregate but reaper lets me pick separate audio in and out options. I'll tinker with it when I get home. Thanks again!