#1
Hi everyone, lately when i turn on my amp for some seconds i hear some craklings, they usually disapper within a minute or so but today when i turned it on, the volume was way lower than normal, it was on 5 and i heard the same volume i usually hear on 1, again after 30 seconds or so the volume instantly went back to normal scaring me to death lol. I bought the amp in 2012 and never changed the tubes so i thought it may be time to change them but since i'm not sure i came here to ask you if that's the problem or it may be something else. Also if i eventually need to change them i'd like to put some good ones in, what do you think may be a good choice? (i usually play rock/hardrock/metal). Thanks in advance and sorry for my bad english.
#2
Reads like your tubes are going out. I suggest to get a new set. You need 3 12AX7's and 2, matched, 6l6s. JJ 12AX7's. I have tried Tungsol 6l6's and they are okay- but I hear that Tube Amp Doctor 6l6's are the bomb.
#4
Quote by Will Lane
Reads like your tubes are going out. I suggest to get a new set. You need 3 12AX7's and 2, matched, 6l6s. JJ 12AX7's. I have tried Tungsol 6l6's and they are okay- but I hear that Tube Amp Doctor 6l6's are the bomb.


+1 may want to pick up a 5751 or 12AT7 also for the PI. I have been doing that a lot with amps lately.
WTLT 2014 GG&A

Quote by andersondb7
alright "king of the guitar forum"


Quote by trashedlostfdup
nope i am "GOD of the guitar forum" i think that fits me better.


Quote by andersondb7
youre just being a jerk man.



****** NEW NEW NEW!
2017-07-07 2017-07-07 Update and a Chat On Noise Constraints *** NEW FRIDAY 7/7
2017-04-13 RUN AWAY from COMPUTERS!!! TCE? RANT ALERT!!!
2017-03-02 - Guitar Philosophy 1001- Be Prepared For the Situation (Thursday 2017-03-02)
2017-02-21 How to Hot-Rod the Hell of your Stratocaster for $50! (Tuesday 2017-2-21)
Resentments and Rambling from a Guitar Junkie
---> http://trashedengineering.blogspot.com/