#1
The footswitch is a 3 button with led type for a peavey special 212. I cant tell if it is the original because it doesn't say peavey on it. Anyhow, it wont switch between lead and ultra. The ultra led lights up but the lead doesnt not. So when the button is pushed for lead the ultra light goes out, lead doesnt come on and the amp doesnt switch. The other two buttons work fine. Any help work be great. If the led burns out on these do they quit working
Last edited by geo-rage at May 18, 2016,
#2
Sounds like you may have a bad connection inside the pedal a wire may have come loose from a switch etc, unplug it and open it up check for loose wires. Hopefully it isn;t a wire break somewhere in the cable between the switch and the plug which is also a possibility.
"A well-wound coil is a well-wound coil regardless if it's wound with professional equipment, or if somebody's great-grandmother winds it to an old French recipe with Napoleon's modified coffee grinder and chops off the wire after a mile with an antique guillotine!"
- Bill Lawrence

Come and be with me
Live my twisted dream
Pro devoted pledge
Time for primal concrete sledge

Last edited by Evilnine at May 18, 2016,
#3
Thanks for the tip dude. A quick test with the ohm meter says the actual switch works fine and there is continuity across the suspect led. In fact the pedal seems to work fine. Could be the amp, could be a wire is swapped around by a very good solderer or there is a very small chance that the led needs to come on in order to trip a relay in the amp. Or something else. Its a 7 pin type input.
#4
So, I have a peavey JSX and the footswitch only works properly if the amp channel select switch is on the ultra channel. I don't know if this is a quirk common to lots of Peavey amps, but I think trying out if the amp switch makes any difference is worth trying.
#5
Quote by wilmearz
So, I have a peavey JSX and the footswitch only works properly if the amp channel select switch is on the ultra channel. I don't know if this is a quirk common to lots of Peavey amps, but I think trying out if the amp switch makes any difference is worth trying.

Peavey normally does this and it's true on this amp too.

https://assets.peavey.com/literature/manuals/80300316.pdf

Check out page 3 at the bottom. Ultra must be selected on the amp for the footswitch to change the channels.
Guitars:
Jackson Kelly KE3 - MIJ (Distortion/Jazz)
Jackson DKMGT Dinky (EMG 81/85)
ESP E-II Eclipse Custom (JB/'59)
ESP LTD EC-1001FR (EMG 81/60)
Fender MIM Strat

Amps:
Mesa/Boogie Dual Rectifier Roadster 212
Laney IronHeart IRT-Studio
Peavey Vypyr 30
Peavey ReValver Amp Sims
TOOOO many T.C. Electronic Pedals. . .
#6
Ah thanks for the pdf! The amp does work like that, where the channels dont select if the gain channel is not selected on the amp. Unfortunately, no dice on that simple fix. Still works the same. Ultra illuminates but then, when switched ultra light goes out and lead light does not illuminate. Well time for a good read....
Last edited by geo-rage at May 18, 2016,
#7
Finally fixed this. It was the plug. A wire had come loose from one of the seven pins. It was easy to solder back on.