#1
Hey guys, I hope this is the right section of the forums.

Anyways, as of lately, I've been experiencing some trouble with my Boss ME-70. Some pots (especially the DIST stompbox) keeps changing the values without me even being near, even when it's left completely on his own (got woken up by the lights once...).

I've tried to find the problem, cleaned the pedal inside and out a few times, but the problem persists.

I'll try to film it in a bit, upload it and try to link it here.

If you know what could be the issue, or if you had a similar issue, please leave a message!
I really hope I can still fix my beloved ME-70

ps. I've only used it at home and repetition rooms.

Edit: I've just noticed another strange thing happening, my turning knob does not match up with the selected effects. Uploading the video shortly.
Edit 2: Video with issue:

Many thanks,
TG
Last edited by Klogmooz at Jul 5, 2016,
#2
Have you been using those od/distortion fx?! You poor soul!! This could very much be a blessing in disguise!

If everything else is working fine I'd start looking elsewhere for distortion.
Fender Mustang/Derfenstein DST> Boss Power Wah> Pedal Monsters Klone> Bogner Uberschall> Walrus Audio Janus> Randall RM20> Line 6 M9> Randall RM20
#3
i had a problem with that on an old korg unit. pain in the ass.

i don't know, but is it a software glitch or a physical thing like a sticky pot?

good luck.
WTLT 2014 GG&A

Quote by andersondb7
alright "king of the guitar forum"


Quote by trashedlostfdup
nope i am "GOD of the guitar forum" i think that fits me better.


Quote by andersondb7
youre just being a jerk man.



****** NEW NEW NEW!
2017-07-07 2017-07-07 Update and a Chat On Noise Constraints *** NEW FRIDAY 7/7
2017-04-13 RUN AWAY from COMPUTERS!!! TCE? RANT ALERT!!!
2017-03-02 - Guitar Philosophy 1001- Be Prepared For the Situation (Thursday 2017-03-02)
2017-02-21 How to Hot-Rod the Hell of your Stratocaster for $50! (Tuesday 2017-2-21)
Resentments and Rambling from a Guitar Junkie
---> http://trashedengineering.blogspot.com/
#4
Tried a factory reset? Or potentially a firmware update?
Quote by SimplyBen
That's the advantage of being such a distance from Yianni. I can continue to live my life without fear of stumbling upon his dark terror.


Quote by Toppscore
NakedInTheRain aka "Naked with shriveled pencil sized bacon In The Rain"
#5
Quote by lucky1978
Have you been using those od/distortion fx?! You poor soul!! This could very much be a blessing in disguise!

If everything else is working fine I'd start looking elsewhere for distortion.


Not really, but it is just very annoying and possibly in the future, I want to sell this thing :P

Quote by trashedlostfdup
i had a problem with that on an old korg unit. pain in the ass.

i don't know, but is it a software glitch or a physical thing like a sticky pot?

good luck.


The thing is, they are fixed pots. Since the warranty was off anyways I decided to take a peek inside. All clean, no sticky pots.. But no software issue either, becauseeee...

Quote by Eppicurt
Tried a factory reset? Or potentially a firmware update?


Yes :\
#6
You're out of the warranty so unless you have a good friend in tech repairs, probably not worth the money to get it fixed. Considering that it's an older model too.

Might have to cut your losses if nobody has experience with this issue and/or can offer advice.

Also if you advertise it on eBay as 'faulty' you might still be able to sell it.
Quote by SimplyBen
That's the advantage of being such a distance from Yianni. I can continue to live my life without fear of stumbling upon his dark terror.


Quote by Toppscore
NakedInTheRain aka "Naked with shriveled pencil sized bacon In The Rain"
Last edited by Eppicurt at Jul 8, 2016,
#7
I'd start by replacing the pot. If it's a non-standard one contact Roland and buy one directly from them. Their parts department is pretty good. If that doesn't fix it, it's fooked. AFAIK you can't reload the firmware and that's what will be rat shit if it isn't the pot.
Gilchrist custom
Yamaha SBG500
Telecasters
Randall RM100 & RM20
Marshall JTM45 clone
Marshall JCM900 4102 (modded)
Marshall 18W clone
Fender 5F1 Champ clone
Atomic Amplifire
Marshall 1960A
Boss GT-100


Cathbard Amplification
My band