#1
So I decided to change my pickups from standard esp passive pickups to emg's and i followed the steps of the official emg youtube channel and the instruction manual.

After wiring it all up for 6 times straight i still have the same problem, the selector switch doesn't work (both pickups are recieving even if not selected)

Does somebody have a solution?

Guitar= ltd ec-10 (1tone 1volume 2 humbuckers and 3-way switch)
#2
Was it an existing 3-way switch, or did the set come with one? It's been years since I installed a Wylde set.
Basically, it's a 3 way switch. It's either broken, or not wired right. Is there an extra glob of solder where it shouldn't be on the switch poles?
Harmony: Stratocaster
Alvarez: F-200
Schecter: Omen 6
Fender: BXR-60
Dean: Metalman Z Bass (Betty)
Egnator: Tweaker 15
Pearl: Maximum
ESP/LTD: EXP-300
Custom: Harley Quinn Bass
Custom: TK-421 Explorer
A steadily growing supply of pedals
#3
ryanbwagsIt was the one that came with the guitar and i use the solderless set so i didn't have to solder anything and it worked just perfect this morning
#4
Laurens420
Well, there you go.
Harmony: Stratocaster
Alvarez: F-200
Schecter: Omen 6
Fender: BXR-60
Dean: Metalman Z Bass (Betty)
Egnator: Tweaker 15
Pearl: Maximum
ESP/LTD: EXP-300
Custom: Harley Quinn Bass
Custom: TK-421 Explorer
A steadily growing supply of pedals
#7
loose wires in the connector box thing is the only other thing I can think of.
Current Gear:
LTD MH-400 with Gotoh GE1996T (EMG 85/60)
PRS SE Custom 24 (Suhr SSH+/SSV)
Ibanez RG3120 Prestige (Dimarzio Titans)
Squier Vintage Modified 70s Jazz V
Audient iD22 interface
Peavey Revalver 4, UAD Friedman BE100/DS40
Adam S3A monitors
Quote by Anonden
You CAN play anything with anything....but some guitars sound right for some things, and not for others. Single coils sound retarded for metal, though those who are apeshit about harpsichord probably beg to differ.
#8
oneblackened I think everything is connected like it should be, maybe something went wrong with stripping the wires and screwing them into the battery buss but i highly doubt that. There is also no problem in the output jack because i get a good signal and when i tap the pickups with a screwdrive they do work
#9
Buy a new switch.
Harmony: Stratocaster
Alvarez: F-200
Schecter: Omen 6
Fender: BXR-60
Dean: Metalman Z Bass (Betty)
Egnator: Tweaker 15
Pearl: Maximum
ESP/LTD: EXP-300
Custom: Harley Quinn Bass
Custom: TK-421 Explorer
A steadily growing supply of pedals
#11
Can you post a picture of your wiring, as well as the diagram you're using?

Do you have a multimeter you can use to check continuity on the switch?
Last edited by Roc8995 at Jul 22, 2016,
#12
I actually just solved it. I am not that smart so i switched up the guitar output terminals, i switched them and now everything works, they sound good. Thanks for helping me!