#1
I have a "Keeley return of the son of fuzz head" and love it but my only problem with it is that I have to turn the output all the way up to actually hear it. I purchased two of them and wondered what could I do to the circuit so that I can add some output to the pedal itself. Any ideas as to what I should look at replacing?
Last edited by nasserliverpool at Aug 12, 2016,
#2
Well first off, how are you powering the pedal? Batteries or adapter. If you're using an adapter are you daisy chaining the power with other pedals? Does it do it with both battery and the adapter? What kind of guitar are you using?
Quote by zgr0826
My culture is worthless and absolutely inferior to the almighty Leaf.


Quote by JustRooster
I incurred the wrath of the Association of White Knights. Specifically the Parent's Basement branch of service.
#3
H4T3BR33D3R

Wow sorry, I completely forgot about this thread my bad. Probably something happened when I posted this. powering by an adapter, and yes I am daisy chaining it with other pedals. Does it both with the battery and adapter and Im using an SG.
#4
Quote by nasserliverpool
H4T3BR33D3R

Wow sorry, I completely forgot about this thread my bad. Probably something happened when I posted this. powering by an adapter, and yes I am daisy chaining it with other pedals. Does it both with the battery and adapter and Im using an SG.



Did you buy both of them and are they both doing that? I would consider contacting Keeley and asking them whats up. I don't think that's how the pedal is supposed to work if you're only getting output when you crank it and I wouldn't really suggest modding them until you find out what is going on with it.
Quote by zgr0826
My culture is worthless and absolutely inferior to the almighty Leaf.


Quote by JustRooster
I incurred the wrath of the Association of White Knights. Specifically the Parent's Basement branch of service.