#1
Hi guys, having a bit of a problem with either Pro Tools or my hard drive. No idea what to do so I am posting this in a couple of places with the hope that some gurus can aid me.

The drive I have is one of these: http://www.wexphotographic.com/buy-g-technology-g-drive-gen6-external-hard-drive-2tb/p1576777?mkwid=scayvehli_dc&pcrid=89741410019&kword=&match=&plid=&product=1576777&gclid=cprhuj_j_84cfrrmgwoddxseia

I have had it for about 4 years and it hasn't given me any problems until recently. I store my Pro Tools sessions on there and read/write audio to/from there.

The computer I am running is a late 2012 iMac 27, OS Yosemite. Pro Tools is version 11 and is fully up to date.

So fairly frequently, like 75% of the time, when I open any session after waking my iMac up from sleep I will be unable to record any audio. I get an error message indicating this after I hit record. I am also unable to save the session. As both of these things involve writing data to the drive, I am assuming this is where the issue is.

So what I then do is close Pro Tools and try to eject the drive. My iMac tells me that the drive is in use, which it isn't, so I force eject it and reboot the drive. After doing this, it will work with absolutely no problems, until I turn off my iMac, come back the next day and then open a session, where I have to then do all of this again.

The only advice I have managed to find was trashing my preferences in Pro Tools, after which I rebooted the iMac multiple times and it seemed to have cleared the problem. Then it started happening again, so I have no idea what else to try.

It is odd because it works absolutely fine during actual use but 75% of the time in order to start working on a session I currently have to open Pro Tools, load up the session, close Pro Tools, force eject the hard drive, reboot the hard drive and then reopen the session which is a pain in the ass to be doing daily.

So I don't know if this is a problem with the drive itself, with some preferences somewhere or just a bug in Pro Tools. Any help would be very much appreciated.
#2
Run disc utility on both the OS and other drive to check for errors.
Try disconnecting your audio drive and connecting it again at start of session.
You might try clearing the PT settings for where it stores termp files, etc.
Try creating new user (admin user) and log with that, see if same error occurs, if not then it is the user PT temp settings in the ~Library folder.
#4
Awesome! Just as a warning - never take these hard drives for granted so make sure you have a second one to back up your music as you can lose everything.
Considering the prices nowadays, you can get an external one 2TB for about $60-$100 and back up all your music files as you never know what could go belly up. I run drive imaging software on mine (Acronis) which I don't think is available for Mac but you can either copy raw data or look at drive cloning facilities on Mac.