#1
This may be an easy answer. Whenever i engage my fuzz(or distortion) pedal, my amp clicks constantly. You cant hear it when im actually playing, but when im just chilling with the strings muted, the click is very obvious. So whats the dealio here?
#3
Yeah, sounds like a potential switching power supply issue. How are you powering things?
www.facebook.com/yourbadinfluence
#4
60hz?
WTLT 2014 GG&A

Quote by andersondb7
alright "king of the guitar forum"


Quote by trashedlostfdup
nope i am "GOD of the guitar forum" i think that fits me better.


Quote by andersondb7
youre just being a jerk man.


***"What Trashed Hoards"*** (updated 2016-11-27)
Resentments and Rambling from a Guitar Junkie
---> http://trashedengineering.blogspot.com/
#5
Sorry for the late reply guys. Ive been super busy. Im powering my pedals through a 9v daisy xhain typr setup.
#6
Quote by riff_captain
Sorry for the late reply guys. Ive been super busy. Im powering my pedals through a 9v daisy xhain typr setup.

Daisy chaining opens up many possibilities for ground loops and other noise sources. I'd power each pedal individually to see if that eliminates the noise.
www.facebook.com/yourbadinfluence
#7
Quote by 8Len8
Daisy chaining opens up many possibilities for ground loops and other noise sources. I'd power each pedal individually to see if that eliminates the noise.


Right on I'll dry it out and see
#8
Ok guys. Again sorry for the long wait. But playing with the power supplies didnt change anything. There is still popping when ever i engage my fuzz or distortion pedal.
#9
riff_captain is it a constant clicking, or a single pop?
www.facebook.com/yourbadinfluence