"Audio device could not be initialized" - Behr.UMC 202 interface, Studio One software

#1
Hey folks,

I'm a long-time (acoustic) guitarist just diving into the world of home recording. Bought an sE X1 mic, a Behringer UMC 202 interface, and tried a couple of different (free) DAWs before ending up with Studio One (the free version of 'serious' software seemed like a good choice).

Now, I'm running into some issues right from the get-go. Afer a few minutes a notification will pop-up saying "The audio device UMC could not be initialized. Please check your hardware configuration and try again.", and Studio One will switch to ASIO4ALL as its 'audio device' - and the laptop speakers will start giving feedback.

I know enough to have downloaded the latest drivers for the interface, but that's about the extent of my knowledgeability.
My best guess concerning the feedback is that, when the UMC interface drops out, the laptop switches to its on-board mic, which could create a feedback loop with its onboard-speakers. But I might be completely wrong. Either way, I figure the main issue to be the interface dropping out, and the feedback simply a symptom of that.

There's such an immense amount of variables here (laptop, interface, software) that I really wouldn't know where to start with troubleshooting. I hope someone with a bit more experience can help me out

Cheers!
J
#2
First I think you have to verify somehow that the Behringer drivers are loaded up properly. 

Since you mention that you have asio4all - I would suggest that you do an uninstall of that first. 
If you don't know how to uninstall in Windows, here's a tutorial:

http://www.pcworld.com/article/2954296/windows/how-to-uninstall-programs-and-apps-in-windows-10.html
(you can just type Apps on the search box and Apps & features will show, uninstall from there).

... or hold on, are the Behringer interfaces with asio4all drivers? So they're using a cheat and not providing bona-fide ASIO drivers by themselves...mother*&^%...

anyway...we'll remove them to start from scratch, so uninstall the asio4all as already specified. Go to Behringer's site and d/load the asio4all drivers again:
http://www.music-group.com/Categories/Behringer/Computer-Audio/Audio-Interfaces/UMC22/p/P0AUX/downloads

OK...looking at the Behringer manual page 34:
https://media.music-group.com/media/PLM/data/docs/P0AUX/UMC404HD_UMC204HD_UMC202HD_UMC22_UM2_QSG_WW.pdf

you first unpack and follow instruction from the drivers install page (step #1). Then you power the interface and connect to the PC via USB cable (step#2). 

Hook up headphones if you can at this stage and make sure the volume is not too high as we don't want to go deaf. 
Go into Studio One and select the Behringer from the audio setup, these tutorials should cover it:

https://www.sweetwater.com/sweetcare/articles/setting-up-your-interface-with-studio-one/

Let me know if you got a different result. 

I know there are some asio4all tweaks, but if you paid over $100 for this interface and can still return it, I'd say opt out for a better one with real drivers, either from PreSonus (since you like S1) or Focusrite, Roland, etc. Let Behringer eat their own garbage...asio4all is a desperate patch at best, not a real driver. 
#3
Hi man, thanks so much for your time.

As the Audio Device in S1 I used to select UMC. Should I have been using ASIO4ALL?

Just now did I find out I had installed the UMC202HD driver rather than the UMC202 one - I couldn't find a driver for the 202, so I figured they were the same. Maybe that's why I get the error message (although it's only after 2 minutes of recording). Then again, you linked me to the UMC22 driver, which is a different interface altogether..

I found a UMC202 driver on driverscape.com (is that trustworthy?), although I can't find the driver on Behringer's website. Somewhere online I found a Behringer-representative answering a user question about the OSX driver that Mac didn't need a driver - I'm using Windows 8.1, though, so not sure if that counts for me, too. The plot thickens.. Any thoughts?

Anyhow, I followed your steps:
- Uninstalled ASIO4ALL
- Downloaded ASIO4ALL USB Audio Driver (from the UMC22, that is)
- Installed (no unzipping, just an .exe)

No change: after about 2 minutes of recording I get the same error message, and S1 switches back to ASIO4ALL as its Audio Device.
ASIO4ALL is using my laptop's onboard mic, by the way.

The UMC isn't my personal property, but I can use it. I didn't pay for it and I can't return it either. I can use it or decide to buy something else.
I'm not very partial to S1, it's just the DAW that got me the closest to actually recording something ^^
I'm hearing good things about Focusrite, so I'm indeed considering making the investment.

I hope you have some more insight! Thanks in advance.

Ps. Another question: is ASIO supposed to replace the driver, or is it somehow 'extra'? Although I've read multiple explanations online, I've yet to understand exactly what it does.
Last edited by Jck. at Mar 6, 2017,
#4
"ASIO4ALL is a generic ASIO driver that works with most audio interfaces".

Basically Behringer cheated, instead of providing their driver, they're using generic 3rd party driver to save $.

So, the asio4all should be your driver that you point to in S1. You need to go into the asio4all app setup, see #3 looks like that



https://www.image-line.com/support/FLHelp/html/envsettings_asio4all.htm

This is for Fruity loops but same principles apply.

You could alternately uninstall the asio4all Behringer driver and get the official asio4all from here:
http://asio4all.com/
Reinstall and post results. It is possible that you have latency, i.e. buffers set too low and audio drops.

Maybe we should go one step back and verify Windows plays music ok from your Behringer interface. See if you can make that interface default in Windows.
http://www.tomshardware.com/faq/id-2080315/change-windows-sound-settings.html
In the Sound box the tab "Playback" is where you pick default interface, let us know what you see there. You should be able to pick um202 in that menu and set as default. This uses wdm drivers so you should probably see it labeled as usb device or by its name. Then anything you play in Windows should show bus thru the default, test it out with youtube videos.

I'm also thinking you might have a rare case where usb3 on some machines needs to be put in "legacy mode" in mobo bios. Try different usb port as well.

In regards to other interfaces, S1 works best with Presonus hardware. Honestly in the $200 and under you're talking budget gear, o in terms of sound they're all similar. Focusrite has problems with clipping on guitar signals, so you'll have to buy one level up from them.

I like Audient iD4 in this range at the moment.

Hopefully we'll get it working
#6
Alright alright, we're getting somewhere.

First of all, got sound out of the interface, no problem there.

Reinstalled ASIO. In ASIO's menu I set up the Behringer as its audio device and, in the same menu, disabled everything under IDT High Definition Audio CODEC (that must've been what was causing the feedback earlier).
I recorded for a few minutes, seemed to work, until the waveform turned into a flat line. I stopped recording and tried again, but I just got a still red line at the beginning of the track. Figured I'd just restart S1. Meanwhile, deinstalled the UMC driver that I didn't need. Fired up S1 again - UMC was gone from the list of audio devices in ASIO's menu. Reinstalled the UMC driver. UMC is back in the list of devices.

Turns out the UMC driver works for a bunch of different interfaces in the product line, including this one. At this point I'm not sure why I'd need ASIO, so I tried to use UMC as the audio device (that is, in the drop-down menu where I'd normally select ASIO). I get the same "Could not be initialized" message. Strange - why would Behringer release a driver that doesn't work, and actually link to a universal, 3rd-party driver that does, on the same Downloads-page?

Anyway, reset stuff to ASIO and went on to record for some 5 minutes, no problem. I'll keep going at it, but it seems to be solved for now
Many, many thanks! You also helped raise my understanding of what I'm doing.

I did some more research on interfaces, and everybody seems to love Audient. I would need at least 2 mic inputs though, so I'd need the id14, currently priced at €239. Do you reckon it'd be worth the upgrade at this point, or would it be better to wait until I gain some more experience and have a better idea of what I want and need?

Thanks again!
J

PS. But man, it does feel like S1 got a low slower in the process..
Last edited by Jck. at Mar 6, 2017,
#7
Jck. that's good news indeed.

Well...if you had the Audient to begin with, probably install wouldn't have been such a mess. It is always good to upgrade from Behringer.

If this is a loaner, play around with it for a bit and if audio doesn't hiccup you're probably okay. Now I see why that unit is about $50 cheaper than its competitors, they just bypassed driver support and coding .

I'm on a 10 input interface, exactly because I always run out on inputs
#8
Heh. Glad you learned something from this whole mess, as well

Sadly, the Red Line of Doom turns out to be somewhat more tenacious than I'd hoped. When I hit Record, instead of a moving green bar with a waveform, I'll see a vertical red line standing still at the beginning of the track. Can't record. I remember having the same issue on-and-off in Audacity a few months back. Any ideas?

Plugging the USB in and out solves the problem temporarily, but after a few minutes of recording it'll just drop out again. Getting a bit frustrated here..
Last edited by Jck. at Mar 6, 2017,
#9
It seems like something is interrupting it and turning it to garbage, maybe something evne simple like losing temporary connection via the USB cable.

Do you have another cable to try?

Video showed that Microsoft midi might need to be disabled, at this point maybe make the pc audio the default interface for Windows (while selecting what you had in there - Behringer or the UMC) just so another program is not conflicting with it.

Trial and error with asio4all, that's what I had to go thru until I got stable settings on mine when I used it.

You can also humor yourself and see if you can't put the USB ports in legacy mode. Let me know what model you have and I should be able to find instructions.
#10
Hi Diab,

Sorry for the late reply, I had a very busy week.

In other news: we got it to work! A friend came over who's a bit more experienced in these things, and we spent some time together setting up and figuring it out. The problem turned out to be the interface's firmware, which needed updating. It's now running smoothly

Thanks again for all your help! Even though you didn't technically solve the problem, you gave me some good insights into how these things work.

Cheers,
J
#11
Jck. - I would've never guessed that they released it with a wonky firmware, but I guess my experience is with every other interface maker, never touched Behringer audio interfaces before, as I had some other questionable quality gear from them that I unloaded fast at a loss.
It really is a "shame on them" moment, but at least you figured it out. I wonder if the savings of $30 were worth it at this point. I had my Behringer lesson, and now you have yours

Good to hear that you're finally able to do what you intended!
#12
Ah well - I didn't pay for it myself, so no loss (not counting the headache, that is). But yes, lesson learned - when I do get around to buying my own gear, Behringer can kindly go suck it.

See ya 'round