#1
I'm having this frustrating issue when using the daw Reaper. Lets say I have a drum track playing as a backing track, and I start playing/ recording with my guitar along with the drums. I hear what i'm playing ON time. but when I play back the recording, my guitar recording is off time.

How can I fix this?

I'm pretty new to DAWs. I'm not running the best laptop, but it has decent specs. My audio interface isn't the best either, and I have been planning to upgrade it. But for the moment my gear seems usable for recording...So why am I getting these problems?

Are there any settings to make this problem go away??

My interface is a tascam us-100. Using asio4all drivers. The laptop specs are

intel core i7-2620m @ 2.70ghz
16gm ram. but only 8 usable
windows 7 64 bit

Any help would be appreciated big time...
#2
Assuming Reaper default settings for what you can see...

Work out what the delay is from the time scale at the top of the recording view, add it to the latency accommodation number XXmS on the very top line of Reaper.

Then go to Options, Preferences, Audio, Recording and at the bottom of the page you will see where you can un-click use audio interface reported latency and put in your own numbers that you have just worked out.

Alternativly can you not get the proper driver for your interface?
Last edited by PSimonR at Mar 11, 2017,
#3
ASIO4All is what you want for that device, the high latency is likely due to having a USB interface plus having your buffer size set too high. You can change this in Reaper's preferences.

Generally you want around 128-256 for tracking and live-monitoring with plugins (64 is better but not attainable typically on pro-sumer gear), and 512-1024 for mixing and playback.
#4
Any reason why you're not using the Tascam factory drivers?

There are two things that could be happening - the software could be putting your audio behind in time or you could be really playing behind in time due to reported latency and don't realize it.


On this interface you have the "Balance" knob which monitors incoming signal and DAW playback, disableaudio monitoring for the channel that you're recording on and just use the dry signal coming from the Input to test if you're still behind. If you are - then there are some bigger issues, as your audio interface time clock is reporting the wrong latency to the DAW, so you might have to look at what Cherry Vulpine suggested to see if it will fix tempo drift...or try the original Tascam drivers.
#5
Quote by diabolical
Any reason why you're not using the Tascam factory drivers? 

This model is probably different but the Tascam interface I bought my boyfriend a while back said to download ASIO4All and didn't come with any factory install discs.
#6
Thanks for all the answers. Ill see what I can do tomorrow.

Today I was trying a few different settings. and the lag stopped. my recordings were actually on time, but then I opened up a new project and I had the same problems all over again.. I'll read over what cherry said, and try to see what I can do. Thanks

and as far as I know there aren't any Tascam factory drivers. When you plug it in, windows just recognizes it as an "audio codec". then I use asio4all. I looked on the tascam site, and googled us-100 drivers. and there's no such thing.
#7
jedigovnaUG - interesting user name.

BTW - see if you don't have some kind of "follow tempo" engaged on the audio files, I get weird drifts like that in S1 when I have the wav file set to match the project tempo and then change tempo.
#8
jedigovnaUG 

Completely uninstall Reaper and then re-install it. It's not normal for it to playback out of time, even on a weaker PC - I've run Reaper on systems much worse than what you have without any issues, even using the onboard sound of shitty laptops - it's a rock solid program, one of the best on Windows. 

On the Tascam site it states to use :  WDM(standard Windows driver)  - maybe try that. 
#10
Latency is the system slowing but the audio still being put in place, now the audio lagging when recording is a different thing. See if you can maybe increase your audio interface latency to max, but at the same time don't monitor your guitar signal thru the interface. If you can somehow split your signal and put thru an amp or something to monitor while recording. I used to do it with a cheapie mixer, take a send out into the DAW and at the same time feed into the mixer with a cheapie fx pedal.