#1
 Hey everyone I hope you can help me out here -

I've had a Tascam 16x08 interface for almost about 2 years now, and I've never had any issues. These days I primarily use it with my PC, running my JBL LSR305 monitors and Audio Technica ATH-50x headphones through it, just listening to music (I know a waste right?). Today I went to record some music on my Macbook in Logic and when I plugged the USB from the interface into my Macbook, the music was distorting really hard. I went on Youtube and played a song to see if it was just Logic and it wasn't. I plugged the cable back into my PC and the same thing was happening, really peaky distortion. I unplugged everything and plugged it back in, reset everything, updated drivers, checked cables and everything. I got kind of nervous because I thought it was a monitor issue, so I plugged my turntable in and played a record and there was no distortion. When I listen to the music in my headphones when they are plugged into the interface, the same distortion is happening. I'm assuming this has to be a problem with the interface since it is happening in both the monitors and headphones that are plugged into it and it has happened on two different computers now, and when I plug my headphones directly into my computers there is no problem. If I'm just brain dead and this is an easy fix or if you guys have any solutions, I'm kind of tapped out here on what to do because this has never happened to me before.

Thanks! 
#2
Do these things have internal drivers with something like a mixer software? Maybe settings got all garbled up?
Did you try different usb ports?
On PC you can go in "Sound and multimedia" properties and make device default and control volume there, so you might be baking that output...poke around in there, maybe flip to tge built-in interface as default and back to the Tascam
Lookup firmware updates or flashing firmware.

Contact Tascam and see what they say.