#1
Ok, I have a Carvin MTS3200 Tube amp.. I'm thinking one of the tubes may be bad but I'm not sure. It still plays fine, except that it has a wierd sound when I play anywhere above.. like 1 lol. It rattles.. but.. not in a way that somethings loose. It has a metal'ish rattle sound. When I take a pencil and tap on the tubes, that's what the problem is, it's not something in the amp. When I tap every one it makes the same noise, so I can't pin point if it's just one tube or not. Is it time for new tubes? Or is something else wrong?
I step up to da mic. Bust a rhyme about my hoes, tippin' on fo' fo's.. and someone shoots me in the face. Because rap is stupid.

Quote by Laces Out Danny
YOU ARE the PIT!!!
#2
*bump*
I step up to da mic. Bust a rhyme about my hoes, tippin' on fo' fo's.. and someone shoots me in the face. Because rap is stupid.

Quote by Laces Out Danny
YOU ARE the PIT!!!
#3
tubes usually last quite a while so it shouldnt break so easily, have to dropped the amp or something? do the tubes appear cracked or broken?
malmsteen on jerry c "you are a rising force"
#4
It did get knocked over at one time, but it didn't start doing this til about 3 months after it was knocked over. The tubes don't appear to be cracked or anything.
I step up to da mic. Bust a rhyme about my hoes, tippin' on fo' fo's.. and someone shoots me in the face. Because rap is stupid.

Quote by Laces Out Danny
YOU ARE the PIT!!!
#5
its probably a pre-amp tube thats making that rattle. Replace your pre-amp tubes and see if it goes away.