#1
Hi everyone. I have had my marshall avt150 half stack for a while now and i have realised that the acoustic simulator channel doesn't sound the same- it used to make my Lp sound like a real acoustic but now it just sounds like a duller version of the clean channel. Does anyone have any ideas what might be wrong with it? Cheers
*Blah blah blah my soul to take*
#3
Sometimes that happens. It may not be the amp, it may be your ears. I have bought an amp and then loved it. A while later I realize it just doesn't sound as good as I thought.
#4
the marshall avt is a hybrid with a single 12ax7 tube in the preamp, if youve had it for a while it may just need to be replaced, I happen to know that all the channels run through that single valve, so just take it to a tech and have him replace it and your amp will sound brandnew, make sure you get a good preamp tube.
#5
i think that the acoustic simulator is the only channel that isnt run through the preamp tube though, since it doesnt have to warm up when i switch the amp on
*Blah blah blah my soul to take*
#7
Quote by Abnormal_Omish
i think that the acoustic simulator is the only channel that isnt run through the preamp tube though, since it doesnt have to warm up when i switch the amp on


Ya I remember hearing that before when I was talking to someone about the AVT series.

Quote by Abnormal_Omish
also how often do i need to replace the tube?


I don't think that you ever have to. I has the Valvetronix series from Vox and you don't have to replace them. They have minimal amounts of power going through them.
Last edited by jmac72187 at May 26, 2006,
#9
no problem, it depends on how often you play an amp, but usually tubes need to be relplaced every year or so, just talk to a tech i.e. where you got your amp and see about getting it replaced, it should be super cheap seeing how you only have one preamp tube.
#10
Quote by Mushok413
no problem, it depends on how often you play an amp, but usually tubes need to be relplaced every year or so, just talk to a tech i.e. where you got your amp and see about getting it replaced, it should be super cheap seeing how you only have one preamp tube.


It is a hybrid though. They don't work the same as tube amps.