#1
Hey guys. I've been using Audacity for a while, used to record with a ****ty mic. Recently I got a line in to connect my guitar to the computer (guitar-amp-computer). However whenever I try to record while listening to the track it records not only my playing, but whatever I hear coming out of the speakers too. So say if I play a midi backing track on Guitar Pro and I want to record the guitar track over it, it records both.

My question is:
How do I make it so it only records the guitar and not the other tracks being played on the computer?
#2
ive never had this problem. are you putting the line in to your computer through a 1/8 mic port or something else.

i just put it from my guitar - amp - 1/8 mic port on computer.
Im too full to swallow my pride!
#3
Quote by italynlprkn
ive never had this problem. are you putting the line in to your computer through a 1/8 mic port or something else.

i just put it from my guitar - amp - 1/8 mic port on computer.

Yes, as I said I can hear my guitar fine, the only problem is when I'm recording, everything that's coming out of the speakers are being recorded.
#5
Quote by BrianApocalypse
Yeah, I get that.

Does moving the mic right away from the speakers help?

No dude you don't understand. I'm using a line in, not a mic. The program just records everything that's coming out of the speakers when I press record and play a backing track to it. Understand?
#6
in audacity there is an option to record the stereo output from your speakers, so its possible you have that selected. i used to use my computer basicly as an amp, so i know there are ways to set it up to play what comes in through the input. if you have both of these selected, thats what happens. check the upper right hand corner of audacity where there is a drop down box. make sure it says line input and not stereo mix. ill look around audacity to see if anything else would do it, but see if thats the problem.
#7
I have this same problem. It is so damn annoying. Im using ACID 4.0, so if anybody can help me, I would greatly appreciate it. I've looked through the options but havent found anything.
Thanks
#8
Is it something to do with the soundcard settings? I don't know, but the line is goes through the soundcard right? Maybe it records everything coming from that.