#1
Okay, a family member of mine messed up my guitar, but I'm working on fixing it. I tried to see if my amp is working, and it won't even turn on. I made sure it was plugged in, and everything was right, and it just doesn't work. Its brand new, I really don't want it to go to waste. Any help is appreciated.
Quote by JMack
Fallinsuburbia is a very intelligent user. Trust him.

Quote by Red.Washburn77

fallinsuburbia looks like an old Egyptian pharoh, carrying a Les Paul Custom, and, while he's only 10, he gets all the girls for looking seven years older than he actually is...
#3
She put gum and pennies in the guitar, and I am wanting to see what she put/what she did to the amp.

so I'm trying to open it.
Quote by JMack
Fallinsuburbia is a very intelligent user. Trust him.

Quote by Red.Washburn77

fallinsuburbia looks like an old Egyptian pharoh, carrying a Les Paul Custom, and, while he's only 10, he gets all the girls for looking seven years older than he actually is...
Last edited by fallinsuburbia at Jun 10, 2006,
#5
tube
Quote by JMack
Fallinsuburbia is a very intelligent user. Trust him.

Quote by Red.Washburn77

fallinsuburbia looks like an old Egyptian pharoh, carrying a Les Paul Custom, and, while he's only 10, he gets all the girls for looking seven years older than he actually is...
#6
check to see if the fuse in the back is blown, if it has one.
"The fool doth think he is wise, but the wiseman knows himself to be a fool." - W.S.
amp clips
amp vids
#7
yeah she might have pulled out the tubes too.

also check she didnt pull/loosen the wire out of the back of the amp.
hard to imagine what else she could have done to an amp unless she had a screwdriver.
Jenneh

Quote by TNfootballfan62
Jenny needs to sow her wild oats with random Gibsons and Taylors she picks up in bars before she settles down with a PRS.


Set up Questions? ...Q & A Thread

Recognised by the Official EG/GG&A/GB&C WTLT Lists 2011