#1
my friend accidently bumped his foot on my amp where the cord goes in and now when i turn it on it doesnt work... the guitar is plugged in and everything and ive tried various cords can someone give me an idea of wuts wrong?
<Raven> I got so baked last night
<Raven> that I WOKE UP high o_o
<Raven> Do you have any idea how euphoric that is?
<Raven> I felt like I was being born.
#2
He could of knocked something put of place in the input, just make him buy you a new one
Ibanez AFS75/Fender Strat Plus > Fulltone Deja' Vibe > Keeley TS808 MOD+ > Fulltone OCD > VanAmps SoleMate > Metro JTM45
#3
make him think that the whole amp is broken now and make buy you a whole new BETTER one
#4
Quote by igotabcrich32
He could of knocked something put of place in the input, just make him buy you a new one



why do that when u can take it apart, and visually see what the problem is? amps really arent that hard to take apart, just label everything as to where it goes and all. my bro knocked the input out of my amp and it took 2 new washers to fix it...
#5
hmm well can anyone tell me a site that will maybe help me in figuring this out? cause i dont rly know a thing about amps...
EDIT: If it helps any when i move the cord around when it plugged in and the amp is on i get a rly harsh sound, and it hums a lot
<Raven> I got so baked last night
<Raven> that I WOKE UP high o_o
<Raven> Do you have any idea how euphoric that is?
<Raven> I felt like I was being born.
Last edited by C.C. Deville at Jul 22, 2006,
#6
sry for the double post but i need help
<Raven> I got so baked last night
<Raven> that I WOKE UP high o_o
<Raven> Do you have any idea how euphoric that is?
<Raven> I felt like I was being born.