#1
Hey, I have an Ibanez RG370DXL. if i take the whammy bar down it wont go back in tune unless you slightly move it back to the middle point. It doesn't go itself. its only a slight bit off. it won't go back to the middle "Zero" point. but it is noticable.

How can i fix it?
#2
add more springs in the back.
mine doesnt do that i have that exact guitar (except right handed)
Quote by ImSheddingSkin
your avatar rules
#3
lol, I once tried to fix that with my rg 1570 by filing the trem edges, NEVER do that. NEVER DO THAT. I now have a lo-pro edge trem installed in it .... yes, the trem was totally worthless after I got my hands on it.
#4
Tighten the spring at the back a bit, only a bit, like quarter twist. Then lube your trem posts using lipbalm/chapstick.

Cover yourself, you're about to be bashed coz of the Edge III
"Play with your ears" - Yngwie Malmsteen, Paul Gilbert
Thats what she said...
UGmusic
#5
Quote by madpickin03
Tighten the spring at the back a bit, only a bit, like quarter twist. Then lube your trem posts using lipbalm/chapstick.

Cover yourself, you're about to be bashed coz of the Edge III


Don't really give a toss what people think to be honest.
#7
Quote by Jpitcairn
Don't really give a toss what people think to be honest.


^right, FLAME HIM!!!


No, sorry lame joke. Hope you'll get it fixed! And if you don't, buy a tremol-no (www.tremol-no.com), for the few moments when you hate your floyd rose!
#9
Quote by Jpitcairn
nope it didn't work.


well, *cowers* the edge III is notoriously crap. So although it seems like a pain, the best thing to do would be to block your trem.
A dwarf might hear you. What then?

My Music