#1
Hi, I just bought two EV 12L speakers. They are the 200w watts each and they weigh a ton. I have a crate cab and I left in two of the old speakers in there. I fired my 5150 up and the two top speakers sounded horrible. No kick to them. The bottom ones had low end like no other. It is just the top ones that are bad.

Could it be a mismatch or speakers? or the wiring is wrong? or just get new celestions...
Thanks for the replies.
#2
Make sure your speakers all have matching impedance. Also, you have to make sure they're wired correctly so that the final impedance of the cab is correct to match the head
Guitars: Custom Lado Earth 2000-3, Custom ESP Explorer, BC Rich KKV, Gibson LP Studio, Greco SG, El Degas Stratocaster, Agile AL-3000, LTD EX-351

Rig:Marshall JVM410H + Marshall 1960A, Boss Noise Suppressor
#3
First off nice job on choosing the speakers, the EVs are really nice.

Secondly, you can't predict the results of mixing speakers so I always reccomend against it unless you can afford to test millions of differnet speakers to find a nice combo. As you've found they more often than not horrible when mixed. I would be inclined to remove the too old speakers and just leave the EVs until you (if you want to) replace the remaining two.

For sale: Early 1985 Ibanez AH10 (Allan Holdsworth signature model) PM for details
#4
My guitar teacher says to put 8 ohm celestions in there because thats what the EV's are. Im just stu7ck on which ones to get. Any suggestions for a guy who plays metal?
#5
Quote by xGuitarnerdx
My guitar teacher says to put 8 ohm celestions in there because thats what the EV's are. Im just stu7ck on which ones to get. Any suggestions for a guy who plays metal?

So you're replacing the EVs or adding to them? If you're adding to them get 2 more EVs because you can have a better idea of how it sounds prior to trying them (and you know for a fact they won't fight each other.)

If you're replacing the EVs then you're going to have to be more specific than metal...

For sale: Early 1985 Ibanez AH10 (Allan Holdsworth signature model) PM for details
#7
at first i thought you might've wired some of your speakers out of phase, but I guess not, though it wouldn't hurt to double check your wiring I suppose.