#1
awhile ago at a practice with my band i noticed that my guitar tone didnt sound quite "right" but i didnt really think anything of it

however at a gig last night it came into full effect. Im assuming either my amp head, cabinet, or perhaps guitar is fried but i can't tell which one.

the best way to describe it is that there seems to be more high end to my sound (there doesnt seem to be as much bass as usual), when i do open note palm mutes the usual low end bassy sustain doesnt last nearly as long as usual. I guess in other words, it sounds a lot "****tier"

perhaps the amp head finally went to ****? maybe a speaker blew? did i fry a pickup?


is there any tests i can do besides taking it to a store and asking "whats wrong?" and trying out a different guitar through the rig setup? (i only have the one ESP for now)
#2
well, if ur tubes go bad that can probably happen, if your pickups get screwed up that could possibly happen, although i don't think thats what it is.

take ur guitar to a local guitar store and try it on those amps, if it works fine, then its the amp.
Quote by master
Yep. It was my birthday and I was wanking in my room and all of a sudden my whole family came jumping in yelling "SURPRISE!!" I guess they were the ones who ended up being surprised.
#3
Quote by lEcheloNl
well, if ur tubes go bad that can probably happen, if your pickups get screwed up that could possibly happen, although i don't think thats what it is.

take ur guitar to a local guitar store and try it on those amps, if it works fine, then its the amp.

Marshall MG's don't have tube...
RIP Jasmine You.

Lieutenant of the 7-string/ERG Legion

Quote by FaygoBro420
Yo wassup, I'm trying to expand my musical horizons if you know what I mean, so can anybody reccomend me some cool Juggalo jazz?
#4
im kinda leaning it towards being a cab problem. i remember when a speaker blew in my 2x12 it had the same symptoms (sloppy gain, wayy to much high end, the bass was virtually eliminated). i suppose ill just wait for the next practice session and try it out on my buddy's setup and go from there