#1
I bought a digitech whammy about a week ago, but i've noticed that the pedal makes clicking sound when I move the threadle. Is this normal? Is it because it's new? could it be the screws? (btw, it doesn't output the clicks to the amp and it also works perfectly except for that clicking!)
#2
I think its supposed to be like that, but dont sig me on this because i dont know anything about whanmys. I think its used like that in the song Through Fire and Flames by Dragonforce
Sigs are too hard to think up
#3
Have you not stepped on it to hard at any point?

you might of just snapped a bit of plastic in it that clicks every time you move it.
Quote by demoniacfashion
Is there any black people on UG?
I don't think a lot of black people play guitar anymore.

Quote by Oasis-fanatic
they all kinda went extinct after hendrix really.


Needless to say, I lol'ed.

Quote by human panda
Appart from being on UG or wanking, thats what i mostly do
#4
Quote by Kingyem0c0re
Have you not stepped on it to hard at any point?

you might of just snapped a bit of plastic in it that clicks every time you move it.


have you got any idea of how i can fix that?
#6
My Whammy was clicking too when I first got it but it stopped buy it self. Check to see if anything is stuck in the little treadle slots
Quote by rabidguitarist
I even tried dressing up as a fly myself, and throwing myself out of the window in the hope that they will follow me. But to no avail.

Quote by daytripper75
we have a Llama forum, and still no drum forum.