#1
Well I get this error when I try to install Windows Installer 3.0 so I can then install .NET Framework so I can then and finally play Neverwinter Nights 2..A game for those who do not know. Anyway, I get this error after trying to install Windows Installer..

update.exe - Illegal System DLL Relocation
The system DLL user32.dll was relocated in memory. The application will not run properly. The relocation occurred because the DLL C:\WINDOWS\system32\SHELL32.dll occupied an address range reserved for Windows system DLLs. The vendor supplying the DLL should be contacted for a new DLL.

I was told to go to Start > Run > sfc /scannow I did that, and restarted my comp, my comp froze on the loading screen, so I had to let it cool down for 15 min then it went up fine, I then tried to install the Windows Installer, and I got the same error. Please help me someone, I'd greatly appreciate it.
#3
I have Windows XP Home Edition.
If this helps, since I last got my new hard drive (It was used from a friend, cleaned out though) It wouldn't let me update past a point, windows updates says it won't let me.. I've tried everything if that's the case.
#4
Screw the retarded game and PC and buy a Mac.
I'm not very active here on UG currently.
I'm a retired Supermod off to the greener pastures of the real world.
#5
There a few things that may be a problem. Is it an original version of windows?
#11
^or buy a PC and DIY
Gear:
Washburn RB2500 (5 String)
Yamaha BB400 Fretless (1981)
Carlo Giordano 3/4 Upright (White)
Cort Action 4 (Stereo-fied)
Orange Bass Terror 500
Orange 1x15 Cab
Boss GT-6 Bass Multi-effects
#12
'buy a mac' doesn't solve his problem, so unless you are going to contribute something useful then keep it shut. I'm sick of Macheads posting in Windows threads with stupid 'answers'.

As for your error, I'll look into it and post something if I can find it. I have an idea but I don't want to post it until its verified.
#14
Are you using Windows XP SP2?

If so then you do not need to install Windows Installer 3.0, its already included with the service pack.

I'm not so sure thats what is causing the problem though, have you ever recieved that error with anything else?
Last edited by LordSephiroth at Jan 17, 2007,