#1
for some weird reason, internet is working EXTREMELY slow, i know it's not my computer because everything except mozilla or explorer is fine

also, when i tried to sign into messenger, it took like 10 minutes and nothing happened

you may think that i'm being impatient, but, it took like 5 minutes to open google, and i have broadband internet (1024 kbps, yes i'm a lucky guy)

so if anybody has some ideas of how to fix this please help me


thanks in advance
#2
Ha n00b i have a speed of 1881 kbps and this is my slow connection. i have a faster one like 2500+ at my other house
Ticking away the moments that make up a dull day
You fritter and waste the hours in an offhand way
Kicking around on a piece of ground in your home town
Waiting for someone or something to show you the way
#4
Sometimes it just lags like that. Don't know why.

Are you using a router by any chance?
Random Metal-X fact:

Metal-X now sponsors: Blood Culprit!


"Ass Fuckingly Loud"

\m/^_^\m/ New Songs Up!!! \m/^_^\m/
#5
Quote by Metal-X
Sometimes it just lags like that. Don't know why.

Are you using a router by any chance?


nope,

it's working a little faster, but, just for load the advanced reply page, it took like 3 minutes (normally it takes around 5 or 6 seconds to load anything)
#6
Quote by deluxity
nope,

it's working a little faster, but, just for load the advanced reply page, it took like 3 minutes (normally it takes around 5 or 6 seconds to load anything)

yah that happens sometimes. one time my speed was 100 kbps it sucked shit. took like 5 minuites to load every picture on the page
Ticking away the moments that make up a dull day
You fritter and waste the hours in an offhand way
Kicking around on a piece of ground in your home town
Waiting for someone or something to show you the way
#7
Quote by deluxity
nope,

it's working a little faster, but, just for load the advanced reply page, it took like 3 minutes (normally it takes around 5 or 6 seconds to load anything)



Ok, it is probly just lag from your service provider.

They are probly updating the system
Random Metal-X fact:

Metal-X now sponsors: Blood Culprit!


"Ass Fuckingly Loud"

\m/^_^\m/ New Songs Up!!! \m/^_^\m/
#9
Quote by Metal-X
Ok, it is probly just lag from your service provider.

They are probly updating the system


ok

it's working a little bit faster right now, thanks
#10
I wish my internet would start lagging. I really need to finish my observational essay for college.
Random Metal-X fact:

Metal-X now sponsors: Blood Culprit!


"Ass Fuckingly Loud"

\m/^_^\m/ New Songs Up!!! \m/^_^\m/