#1
hi,
i have a peavey classic 50 and every now and again i get this weird crackling sound that comes through the speaker, it doesnt seem to effect the sound of the guitar coming throught the amp but i'm worried that it could get worse/lead to something worse if it goes un-checked. Anyone have any idea what this could be or had similar problems???

Thanks for the help
#2
loads o stuff it could be:
Dodgy leads
Crapped out tubes (how long they bin in?)
Shitty pups
Lose conections
D-U-F-R-A-I-S


Quote by darkstar2466
WRONG.

The only reason it exists is because drugs get people fucked up, and people love getting fucked up.

#3
o sorry yeah its definately the amp coz it does it when the guitar isnt even plugged in, ive had the tubes since i got the amp about 2 yrs ago ish, could it be those?
#4
it sometimes just happens because of the power supply isn't grounded properly and other electronic devices in the room like lights computers etc...
#5
+1, probs that, or the tubes, if you'd had em in two years there probs a bit dead by now. Check round the back of the amp, what colour are they glowing?
D-U-F-R-A-I-S


Quote by darkstar2466
WRONG.

The only reason it exists is because drugs get people fucked up, and people love getting fucked up.

#6
Quote by _-Skeletor-_
it sometimes just happens because of the power supply isn't grounded properly and other electronic devices in the room like lights computers etc...


ahh ok, the power outlet has quite a load on it so it could be that, ill mess around with it and see if i can get it to stop...
#8
Quote by Atreideslegend
theyre glowing a sorta bright orange colour


Hmm, there probably allright then. Its probably just bad wiring or grounding in the amp, get it checked out.
D-U-F-R-A-I-S


Quote by darkstar2466
WRONG.

The only reason it exists is because drugs get people fucked up, and people love getting fucked up.