#1
When i play my guitar with distortion on it sounds fine but recently when i turn the distorion off and play the guitar sounds a little dirty like theres very little distortion, Did i blow the speaker in my amp?
#2
nah.. it's just ur pick up... some pick ups have that effect to sound better for distortion
Quote by musical donkey
cyclobs you are demented..... in a good way
#3
its like that on both of the guitars i have, idunno maybe im just halucinating from not sleeping
#4
cheap amp?

if it was blown you'd get next to nothing along the lines of sound.

would kind of guitars? or pickups? some guitars have horrible cleans...
ESP CUSTOM SHOP HORIZON
FENDER USA STRAT
JACKSON DK2M
Peavey 5150ii w/ Marshall 1960DM cab
#5
have u tryed changing the pick ups?
Quote by musical donkey
cyclobs you are demented..... in a good way
#6
Quote by cyclobs
have u tryed changing the pick ups?

the one guitar is a used Epiphone Les Paul Speciall II which i just bought so the pickups on that should be fine but the other guitar is an Ibanes GIO i bought from a friend and the pickups are kinda messed up on that one but i took it to the shop and when i brought it in the bottom pickup worked fine and when i got it back the top one worked but only when the switch is in the middle so im thinkin it just needs to be wired properly
#7
yer wiring is prob stuffed on it....
Quote by musical donkey
cyclobs you are demented..... in a good way
#10
i'm had a lil 10w ss at full ball for about a yr...lol.. dunno if it liked it very much.. but it's still good.... i wonder if it bein n ibanez change anythin
Quote by musical donkey
cyclobs you are demented..... in a good way
#11
What????

i don't think having something at full blast would mess it up, idk, maybe the speaker's gone in it??? you never said what the problem was.....
#12
Quote by Chad11491
What????

i don't think having something at full blast would mess it up, idk, maybe the speaker's gone in it??? you never said what the problem was.....

im not too sure what the problem is all i know is before it was fine but now it sounds crappy when i play clean
#13
u sure u using the clean channel.. just cause u turned the gain off dont mean it's a clean channel.. just got next to nothing gain in ur sound.. my 10w does that but it has a overdrive button to turn that off so it's just clean... does ur amp have that?
Quote by musical donkey
cyclobs you are demented..... in a good way
#14
my amps an older fender the only knobs it has are volume,master,gain,mid,trebble,bass, and reverb, when i play clean i just turn the distortion pedal off
#15
ah.. well i dunno.. either ur using ur distortion pick ups or.... i dunno.. only thing i can think of that would cause that
Quote by musical donkey
cyclobs you are demented..... in a good way
#17
where do your levels and masters sit?

cause i think you can drive your amp a bit by having your volumes really high and your master low....

just check that?
ESP CUSTOM SHOP HORIZON
FENDER USA STRAT
JACKSON DK2M
Peavey 5150ii w/ Marshall 1960DM cab