#1
I just got a Guv'nor pedal from my mate, it's about 8 years old and hasn't been used in ages. The knobs were all stuck in place, so I unstuck them just by forcing them loose.

There are five knobs on the Guv'nor:

Gain - Bass - Middle - Treble - Level

The three EQ knobs work fine, however the two outer knobs, the GAIN and LEVEL, are stuffed. Firstly, they turn all they way around, ie, 360 degrees instead of just 0 to 10. Secondly, turning them has no impact on the sound.

How do I fix this?

Also, there is a massive buzz/hum/feedback/noise when I plug into my Classic Combo. However there was no major noise problems when I plugged into my Thunder, which I found strange.
Ibanez RG1570
Fender Mexican Fat Strat

Engl Thunder 50 Reverb combo
Engl Classic Combo 350C
Line 6 Flextone III
Roland Microcube

Line 6 Podxt Live
Marshall Guv'nor
#2
Never mind, fixed it.
Ibanez RG1570
Fender Mexican Fat Strat

Engl Thunder 50 Reverb combo
Engl Classic Combo 350C
Line 6 Flextone III
Roland Microcube

Line 6 Podxt Live
Marshall Guv'nor
#4
I took the plastic knobs covers off, and the actual knob, the metal thingie, worked fine. Turned between 0 and 10 like usual.

I must have worn down the plastic when trying to force the knob to turn.

I found that hard to explain, lol. You get me?
Ibanez RG1570
Fender Mexican Fat Strat

Engl Thunder 50 Reverb combo
Engl Classic Combo 350C
Line 6 Flextone III
Roland Microcube

Line 6 Podxt Live
Marshall Guv'nor
#5
thats what i was gonna say....
<*ELECTRO*>
XXXXX
XXXXX

______________________________________
Quote by ShadesOfNight
I'm not a sadistic person, but I'd like to pull the wings off every fly in the world so they all starve to death or get eaten alive by spiders

#6
Quote by Kris_man
I took the plastic knobs covers off, and the actual knob, the metal thingie, worked fine. Turned between 0 and 10 like usual.

I must have worn down the plastic when trying to force the knob to turn.

I found that hard to explain, lol. You get me?


Haha yeah.