#1
I went to the local music store and was talking with one of the guys there, and when i asked him what he thought about the S-1 switch he said that he's often had to deal with it getting stuck in one position or the other on a couple of his Strats and it wouldn't go back. The switch broke, apparently. Has anyone else had this problem?
#2
ive had a strat with s-1 for a couple years now and no problems. great little system
#3
I have had a Strat with it since 2005 and it's still working perfectly...
ಠ_ಠ ಠ_ಠ ಠ_ಠ ಠ_ಠ ಠ_ಠ ಠ_ಠ ಠ_ಠ

Quote by Xp3ns1v3
I thought it was illegal for women to use the internet.
#4
I had a Strat since 2004 and nothing has happened.
Quote by Cody_Grey102
I was looking at a used Warwick Vampyre LTD 5'er for about $200. I went home to grab my wallet and came back and some jerk with an epic beard got it already..
#6
I have a P-Bass with it and no problems so far
Quote by Bumper
Looks like you had a big bowl of Downs Syndrome for breakfast.



Member of the Bass Militia, PM Nutter_101 to join

Lover of Ashdown? Join the Ashdown Army!
#8
Frankly even if it did stick (which I've never heard of happening), you can just take the knob off the pot and unstick it/clean it.
Quote by MetalUpTheAss
Sounds to me like an excuse.

"Honey, I've got to buy a new bass! This diamond is made of a dead guy! I made him a promise!"


Most Bitter/Cynical member of the Bass Militia. PM DinkyDaisy to join.
#9
^Yeah. Try not to pour maple syrup on the switch or something and you should be good to go.
Quote by Cody_Grey102
I was looking at a used Warwick Vampyre LTD 5'er for about $200. I went home to grab my wallet and came back and some jerk with an epic beard got it already..