#1
yeah, so i have the RP 80 with the whammy effect on there. when i push the pedal down on the +1 octave mode it sounds like theres some time of rotary tremolo. same thing when its on -1 octave. and to top that whenever the whammy is on, it sounds like for some reason its mixing a lot of reverb in with it. i dont know if this is a problem or just what happenes for getting the $80 model
Quote by Joey Walker
Quote by anaoshak
look at all those knobs, he must have a mean tone.

Bottle caps buddy, they are bottle caps



Quote by Shib
The internet: Men are men, women are men and little girls are FBI agents.
#2
Sounds like it could just be cheap.. Not sure. What kind of amp are you using? I used a DigiTech Whammy ($250) on a Line 6 the other day, and it ****ed up and sounded bad a lot, when I know the pedal is high quality. Could just be the amp, if it's digital.
Main Gear:
Cort G-Series 254
Takamine EG345C 12-String
Fender Squier P-Bass

Peavey Classic 50
Laney HCM65B

$75 Junk Drums w/ B8 Hats/Crash/Ride
#3
well the amp is a vintage 1965 Sears XL5 so i doubt that would be it.
Quote by Joey Walker
Quote by anaoshak
look at all those knobs, he must have a mean tone.

Bottle caps buddy, they are bottle caps



Quote by Shib
The internet: Men are men, women are men and little girls are FBI agents.
#4
Yeah, probably not. Could just be the pedal then.
Main Gear:
Cort G-Series 254
Takamine EG345C 12-String
Fender Squier P-Bass

Peavey Classic 50
Laney HCM65B

$75 Junk Drums w/ B8 Hats/Crash/Ride