#1
alright guys...big problem

my JCM900 just went ker-plop on me.

i turned it on and let it sit for about 5 min, then turned it on to play. Got to play for about 15 min, then it lost all power. I changed power sockets and everything. It was plugged into a surge strip before it died. idk what to do. my baby is dead
[IMG]http://img398.imageshack.us/img398/9148/dawhip005jf4.jpg[/IMG]

Quote by SuperSamuraiGuy
Thanks for answering all my question ssguitar



JCM900 FOR SELL!
#2
tube problems? make sure none of the tubes came loose. turn it back on, see if they light up. see if anything looks funny.

it might also be a transformer.
Quote by ClassicAxe

consider anything derek suggests, He IS a gain VVhore you know
Quote by jj1565
derek, will you go out wt me?

President Gain Whore -group on profile
#3
erm, maybe blown the fuse or blown the tubes
Quote by Zangetsu 101
Girl (Ned/chav) annoying me on the bus.

Me "Have you ever bled out your arse-hole?"

Her: Facial expression was priceless - "What??! Noo!"

Me: "Well if you want to keep it that way, **** off."

She then turned away and whimpered.
#4
it wasnt a tube bc it was like the power just wasnt getting to the amp (think tripping a breaker or the power being down in an area). i dont want to have to take it to a shop but i will if need be
[IMG]http://img398.imageshack.us/img398/9148/dawhip005jf4.jpg[/IMG]

Quote by SuperSamuraiGuy
Thanks for answering all my question ssguitar



JCM900 FOR SELL!
#5
does the power switch light up? if not, check the fuse. If the fuse is blown, replace it. If it blows again take it to an amp tech.

If you don't really know a lot about amps, take it to a tech
#6
Quote by Gutch220
does the power switch light up? if not, check the fuse. If the fuse is blown, replace it. If it blows again take it to an amp tech.

If you don't really know a lot about amps, take it to a tech


no the power switch doesnt light up. and im kinda scared about geting into my amp (its a 212 combo btw) so getting to the fuses might be a problem
[IMG]http://img398.imageshack.us/img398/9148/dawhip005jf4.jpg[/IMG]

Quote by SuperSamuraiGuy
Thanks for answering all my question ssguitar



JCM900 FOR SELL!
#7
its either your tubes or your fuse it seems like. take it to a tech id say, if its your baby its worth the money no?
MY RIG:

Gibson Explorer '73 reissue, Classic White
Schecter Blackjack S1
Crate Stack


Thats noise violation in a box!
#8
Quote by ssguitar
no the power switch doesnt light up. and im kinda scared about geting into my amp (its a 212 combo btw) so getting to the fuses might be a problem


The fuse should be right in the open on the back of the amp. They have them there for a reason, so you CAN replace a fuse and if it blows again you're supposed to take it to a tech.

I don't think you have to 'get into' your amp at all to get at the fuse..
#9
ok lemmie check ill get back at ya in a second
[IMG]http://img398.imageshack.us/img398/9148/dawhip005jf4.jpg[/IMG]

Quote by SuperSamuraiGuy
Thanks for answering all my question ssguitar



JCM900 FOR SELL!
#10
sry for the double post but am i an idiot or is there a certain way to get the fuses out. My first tube amp and i was used to the fuses in house stereos
[IMG]http://img398.imageshack.us/img398/9148/dawhip005jf4.jpg[/IMG]

Quote by SuperSamuraiGuy
Thanks for answering all my question ssguitar



JCM900 FOR SELL!
#11
The fuses are right where it says Output Valve Fuse. Just unscrew it out



look for burnt/broken fuses
#12
Or just replace them anyway, they only cost the same as a pack of sweets. I've had some fuses blow pretty spectacularly...well, for fuses , cracked the casing and all black inside. Sometimes though you can't even tell it's blown.
Actually called Mark!

Quote by TNfootballfan62
People with a duck for their avatar always give good advice.

...it's a seagull

Quote by Dave_Mc
i wanna see a clip of a recto buying some groceries.


stuffmycatswatchontv.tumblr.com
#13
thanx i def had a blown fuse. i couldnt fig out how to get it out, but i finally got it. im an idiot. i know. imma go tommarow to get fuses for it!
[IMG]http://img398.imageshack.us/img398/9148/dawhip005jf4.jpg[/IMG]

Quote by SuperSamuraiGuy
Thanks for answering all my question ssguitar



JCM900 FOR SELL!
#14
just remember that a fuse it there to blow in case something is wrong. You could still have a damaged amp
#15
im going to change out the fuse...then if it blows again. I will have to save up money then take it to a shop. oh btw where is teh serial number on my amp?
[IMG]http://img398.imageshack.us/img398/9148/dawhip005jf4.jpg[/IMG]

Quote by SuperSamuraiGuy
Thanks for answering all my question ssguitar



JCM900 FOR SELL!
#16
the serial number on your amp is probably just the bar code sticker. Pre-1991ish they had the serial numbers engraved with the A,B,C,D,etc system