#1
OK I just realized that the effect loop on my amp is either messed up or incompatible
with MXR effects! The first apparent symptom appeared with I got my EVH Flanger,
plugged in the effect loop it creates a weird "pop" sound in synch with the speed knob. But plugged directly in the amp input, everything's fine!? Now it's my Phase 90...it does not create the same "popping" sound but sound like sh*t with any of my distortion boxes when it's in the fx loop, but great with the amp's overdrive.

Could it be the MXR's? Cause the others fx such as the Bosses or EHX sound great!
Or is it just the amp's fx loop incompatible with MXR?
((( KoskineN )))

-ESP LTD EC-1000 Deluxe VHB
-Fender Telecaster Lite Ash
-Mesa Roadster 2x12 combo
-Fulltone Clyde Dlx, OCD, '69
-Boss BD-2, CE-5, DD-20, TU-2, RC-2
-MXR Phase 90 & EVH Flanger
-EHX Little Big Muff - Holy Grail - Micro POG
#2
maybe its because the loop is in a different stage of the effects chain.
#3
Sory but what do you mean by "different stage of the effects chain"?
((( KoskineN )))

-ESP LTD EC-1000 Deluxe VHB
-Fender Telecaster Lite Ash
-Mesa Roadster 2x12 combo
-Fulltone Clyde Dlx, OCD, '69
-Boss BD-2, CE-5, DD-20, TU-2, RC-2
-MXR Phase 90 & EVH Flanger
-EHX Little Big Muff - Holy Grail - Micro POG
#4
I'm guessing he means that the loop is in between the preamp and power amp, instead of out in front. And you said you ran a distortion in the effects loop with your Phase 90? That's the reason, probably. Distortion doesn't sound good in the effects loop for the most part.
#5
ok I wasn't clear enough...the distortion is NOT in the fx loop. The Phaser IS in the loop but the dist are in the front input of the amp...sorry about this!
((( KoskineN )))

-ESP LTD EC-1000 Deluxe VHB
-Fender Telecaster Lite Ash
-Mesa Roadster 2x12 combo
-Fulltone Clyde Dlx, OCD, '69
-Boss BD-2, CE-5, DD-20, TU-2, RC-2
-MXR Phase 90 & EVH Flanger
-EHX Little Big Muff - Holy Grail - Micro POG
#6
Quote by cokeisbetter
I'm guessing he means that the loop is in between the preamp and power amp, instead of out in front.

yeah, thats what i meant, i did a crappy job of explaining it :P
#7
^^Ok. Well, then wierd. And it only happens in the effects loop of the amp, only with your MXR pedals. Hmm. That just seems wierd. It couldn't be that it's not compatible with MXR pedals, cos... that doesn't happen.
#8
I know it's weird.....someone from a thread on the problem of my EVH Flanger told me that the fx loop could overload the effect, creating the popping sound....so maybe it's the same thing happening for my Phaser? So my amp does not like MXR's!

Maybe it's time for a new amp!
((( KoskineN )))

-ESP LTD EC-1000 Deluxe VHB
-Fender Telecaster Lite Ash
-Mesa Roadster 2x12 combo
-Fulltone Clyde Dlx, OCD, '69
-Boss BD-2, CE-5, DD-20, TU-2, RC-2
-MXR Phase 90 & EVH Flanger
-EHX Little Big Muff - Holy Grail - Micro POG
#9
yeah, FX level runs at line level instead of the lower guitar output signal. that's your problem.
Quote by corduroyEW
Cheap amps are "that bad". They suck up your tone like cocaine at Kate Moss' party.


I am Michael!
#10
But even when I turn down the fx level, the problem is still there....Do you think it could be fixed?
((( KoskineN )))

-ESP LTD EC-1000 Deluxe VHB
-Fender Telecaster Lite Ash
-Mesa Roadster 2x12 combo
-Fulltone Clyde Dlx, OCD, '69
-Boss BD-2, CE-5, DD-20, TU-2, RC-2
-MXR Phase 90 & EVH Flanger
-EHX Little Big Muff - Holy Grail - Micro POG
#11
the effects loop level would be changed after the loop.

and if you mean actually on the fx, turning the level wouldn't change anything.
Quote by corduroyEW
Cheap amps are "that bad". They suck up your tone like cocaine at Kate Moss' party.


I am Michael!
#12
So I'm stocked with this problem!?....
((( KoskineN )))

-ESP LTD EC-1000 Deluxe VHB
-Fender Telecaster Lite Ash
-Mesa Roadster 2x12 combo
-Fulltone Clyde Dlx, OCD, '69
-Boss BD-2, CE-5, DD-20, TU-2, RC-2
-MXR Phase 90 & EVH Flanger
-EHX Little Big Muff - Holy Grail - Micro POG