#1
When i replace the fuse for my tube amp should it just slide ina nd click because no matter how hard i push it it wont click? does the amp need to be in standby or something?
#2
Dude, the amp is going to the receiving its voltage through the fuse, logic says to turn it off, yeah?
It depends on the fuse type - some you push in and they have a screw on cap, others just pop into place. Do the opposite to what you did to take it out.
"Everybody, one day will die and be forgotten. Act and behave in a way that will make life interesting and fun. Find a passion, form relationships, don't be afraid to get out there and fuck what everyone else thinks."
#3
well when i got it the fuse was already in and the fuse popped out while playin...it doesnt seem to screw in...its a mesa triple rec if that helps u to eliminate what kind of fuse installation it might require?
#4
find a picture on the net of the type of fuse.
"A wise man once said, never discuss philosophy or politics in a disco environment." - Frank Zappa
Quote by Jinskee
Don't question the X.
<Frenchy> I'm such a failure
#5

well i dont know if you noticed or not but your amp says "unplug power before removing fuse" so yes, turn it off.
It looks like you just screw it in
Just pop one end of the fuse onto the cap then screw it in
Gibson Explorer
Jackson Soloist SL3
Orange Tiny Terror
Mesa 2x12
#6
it doesnt screw in....i try pressing it in and it goes in but then recoils back...it just wont stay in place it fits and everything its just loose...i dont think there are any parts missing either...what should i do?
#8
Just read the writing on the plastic end-cap of the fuseholder.

You push it in, and turn it clockwise, about 1/4.

done.
Meadows
Quote by Jackal58
I release my inner liberal every morning when I take a shit.
Quote by SK8RDUDE411
I wont be like those jerks who dedicate their beliefs to logic and reaosn.
#10
it still doesnt do it i pushed it right in and turned it and it wont go in! argh!! wot the hell is goin on it it jst comes out...nlot completely but just loosely
#11
Quote by Systemfan2005
it still doesnt do it i pushed it right in and turned it and it wont go in! argh!! wot the hell is goin on it it jst comes out...nlot completely but just loosely


Look dude, are you putting the cap on? You've had pretty damn explicit instructions on how to do it, I can't see how you could possibly have any problems.
"Everybody, one day will die and be forgotten. Act and behave in a way that will make life interesting and fun. Find a passion, form relationships, don't be afraid to get out there and fuck what everyone else thinks."
#12
i put the fuse in the cap and then ut the cap into the fuse port in the back of the amp..it fits in perfectly but it doesnt have like a mechanism wher it just clicks into place, neither does it screw in...and i dont think any parts that would fit the mechanism are missing either.