#1
When I first got my amplifier (Fender Frontman 25w, the distortion sounded pretty good. Obviously not the greatest of any ever, but it sounded like it should.

For some reason a little while ago, it changed. It is hard to explain how it sounds now, but I will try. It is kind of distorted, but it sounds really really hollow. It is almost like clean tone, with a bit of distortion and a really hollow, echoing sound.

Sorry my description is not very good, but it is hard to explain. Hopefully someone can recognize the problem and help out.


Thanks a bunch!
#2
have you not changed the setting on on of the knobs by mistake eg from 8 to 5 or something
#4
Quote by roryp15
have you not changed the setting on on of the knobs by mistake eg from 8 to 5 or something


I don't think so. What knobs would affect it that much?
#5
gain? the last amp i had i had the same problem and i thought i never had changed any knobs but wen i looked closely i had
#6
I have fiddled with the gain trying it on pretty much everything and it still sounds the same
#8
ok turn everything to 0 and then dail into the sound that you had . That normally works for me if ive lost a good setting ( if that is the problem of course , hope it is)
Gibson SG spesial

Marshall 1987X MKII Head
Genz Benz El diablo 100 Head
Genz Benz Gflex 212 cab.

Korg AX1500G multi effects pedal
#9
Quote by t3mp
ok turn everything to 0 and then dail into the sound that you had . That normally works for me if ive lost a good setting ( if that is the problem of course , hope it is)


Thanks. I will try that out tomorrow.

I don't know if it is just the sound though. I might be best taking it into a guitar store and asking them. I don't really want to though.
#10
It could be broken, but you should dial in your tone before you jump to concluscions.
hoimhi0et0hm03oi
#12
Quote by beckyjc
Hollow echoing sound?
Not to sound idiotic but have you fiddled with the reverb?


No, it is not like reverb echoing. It doesn't exactly echo but it sounds really hollow and flat rather than ripping distortion if that makes any sense.
#13
Check the basic things first, cables, knobs on your guitar, EQing, input jack, speaker connection, try a diffeernt guitar into it. If you're absoloutely sure it's nothing embarrising like that then take it to a tech. You don't wanna be messing about with it if you don't know what you're doing.
#14
like it would sound if you rolled back on youre guitar volume knob and a bit on youre tone knob ??
Gibson SG spesial

Marshall 1987X MKII Head
Genz Benz El diablo 100 Head
Genz Benz Gflex 212 cab.

Korg AX1500G multi effects pedal
#15
I've experience of this amp myself, and generally it has two proper distortion settings

1) cool distortion (like the one you were talking about)
2) something akin to the problem, and the only way you get that is all dials to zero.

It's probs got something wrong with it.
Epiphone Dot-335
Fender USA Tele
'82 30th anniversary Les Paul goldtop
1965 pre-CBS Fender Jaguar

Crybaby
TS-9
turbo rat
Ge-7
+many more

Fender Twin Reverb
King's Full-tube 100 watt half stack. - £300
#16
i have a dodgy input jack and sometimes it does exactly what your describing, and the distortion sounds weaker, and yeah, hollow and lifeless, so its probably a dodgy connection youv got somewhere
MARK ALL THAT APPLY:

[_] [_] [_] [_] [x]

Quote by cagnius
Shut up. Actually, higher mods...can we ban him for being a cunt?