#1
Ok, heres the deal. I got a Fender Hot Rod Deluxe 40 watt tube amp. When I am playing with the distortion on and hit the footswitch to go to no distortion it makes an annoying pop when i hit the switch. It does not pop when going into distortion, nor does it pop when i'm not playing and switch out of distortion. Any possible fixes or do i gotta live with it.... Im thinking about getting a disrortion pedal anyway because the distortion that comes with this amp isnt great for a lot of styles. Any help is greatly appreciated
Quote by pmeg568c
oh man, seems as though i totally forgot about anal

My Gear
Fender American Deluxe Stratocaster
Fender Standard Strat
Boss ME-50 Multieffect
Fender Hot Rod Deluxe
#2
Yeah man, it does that. I don't think that there is anything you can do about it.


The overdrive is great for blues and rock but when you want to get any heavier than that you need a distortion pedal.
Ticking away the moments that make up a dull day
You fritter and waste the hours in an offhand way
Kicking around on a piece of ground in your home town
Waiting for someone or something to show you the way
#3
im wondering, does this kindof thing have to do with the fact that its a tube amp or am i completely wrong
Quote by pmeg568c
oh man, seems as though i totally forgot about anal

My Gear
Fender American Deluxe Stratocaster
Fender Standard Strat
Boss ME-50 Multieffect
Fender Hot Rod Deluxe
#4
damn i thought it said pooping amp
OAKLAND A's - 9 TIME CHAMPS!!

DUKE BLUE DEVILS - 4 TIME CHAMPS & 19 TIME ACC CHAMPS!!

OAKLAND RAIDERS - 4 TIME LEAGUE CHAMPS!!

GOLDEN STATE WARRIORS - 3 TIME LEAGUE CHAMPS!!

SAN JOSE SHARKS - NONE LOL!!