#1
the wah/volume pedal on mine now has an annoying squeak,anyone have this?if i wd40 it is there a chance of it leaking inside and ruining it?
#2
lol, its a problem with the floor pod and the pod xt live, they screwed up on of the washers holding the pedal. Mine did it after about a week, i just took it apart, loosened it a lil bit and put some grease on the bolt that it pivots over........ i wouldnt suggest wd40 cuz it could get somewhere its not suposed to be. Hope that helps
“I used to be made fun of because I’d stay alone at home on weekends and play the guitar, but once I got good on the guitar, I got all the pussy I wanted"-EVH

Schcter C-1 Classic - Emg 81/85 @ 18 Volts
Peavey Valveking 112
Line 6 POD XT Live
#4
i hear ya on that, i think they will replace the washers for you if you mail it in or something, there is a guide on there website to fixing it if you dont want to mail it, but if you mail it in no pod for a few weeks :'(..... i think its only a problem on something like 30% of em, obviously were both in that 30%
“I used to be made fun of because I’d stay alone at home on weekends and play the guitar, but once I got good on the guitar, I got all the pussy I wanted"-EVH

Schcter C-1 Classic - Emg 81/85 @ 18 Volts
Peavey Valveking 112
Line 6 POD XT Live
#6
sorry bout the long response, i looked on their site for a few and couldnt find it except for in their forums where it says dont use wd40 ever lol, just look around and im sure youll find it
“I used to be made fun of because I’d stay alone at home on weekends and play the guitar, but once I got good on the guitar, I got all the pussy I wanted"-EVH

Schcter C-1 Classic - Emg 81/85 @ 18 Volts
Peavey Valveking 112
Line 6 POD XT Live