#1
ok so i have a line 6 spyder 2 (its a 30 wat if that matters) and a few friends came over and one was turning all the effects knobs while i was playing and then it just started to buzz like all that was coming out was overdrive. And you cant here the guitar play through it at all. I dont know if its blown or if it can be fixed. Anyideas on how to fix it or wats wrong with it.
#2
oh so someone else asked me this ? before
the answear is easy


this is what you do
you get a hammer and start beating the sht out of it until its nothing but
a pile of broken plastic and circatry

and then go buy a new one because those amps suck balls

or just take it to a dealer man it will cost you like 20 bucks to get it fixed
because if you cant figure it out
#3
It sounds like something overheated and burned. Post another thread for some new amp recommendations. When Spiders die they tend to stay dead. Like most solid state or digital amps the repair costs usually exceed the value of the amp.
#4
ok for one i personally love my amp and i have only had it for a few months and nothing has happend to it. But none of my freinds play electric and i knew i should have told him to stop messin with it. Some overheated or burned sound about right. Can anybody give me a rough estament on how much it would cost? I have an older friend who is pretty good at stuff like that so maybe i wouldednt have to pay. Would we be able to fix it or no?
#5
If its under warranty take it back to the shop. If not your average amp tech charges about $50-100 per hour. If your friend is knowledgable enough it would be worth a try. Maybe your friend will see an obvious burned circuit.
#6
Quote by fendr15
it just started to buzz like all that was coming out was overdrive. And you cant here the guitar play through it at all.

...and it's a Spider? Sounds like it's working fine to me
#7
Ya i know everybody has a problem with spyders but i love it. Anyway i will see if he can find one.